"Could not create OpenCL device" Houdini Console notification

   29438   15   6
User Avatar
Member
33 posts
Joined: 9月 2018
Offline
I've seen some posts re: this issue but all have involved adding some code to a Houdini environment variable? to get it to use my GPU rather than CPU. I've only just started learning Houdini so I have no idea on where to add code as an environment variable or whatever it is I'm meant to do. Just hoping someone could explain to me in relatively simple terms on how to fix this. Cheers.

Attachments:
H17_OpenCLdevice_error message.jpg (83.7 KB)

The only devil I know is in the detail.
User Avatar
Member
4 posts
Joined: 2月 2016
Offline
If you are using Windows then the houdini.env file will be in the Windows documents folder. Open it with the notepad editor and underneath all of text that's already in there paste this code.

HOUDINI_OCL_VENDOR = NVIDIA Corporation

HOUDINI_OCL_DEVICENUMBER = 0


Then save the env file and start up Houdini again. When Houdini starts click the ‘help’ tab. Then at the bottom of the list choose ‘About Houdini’ and in the window that pops up put a tick in ‘Show details’ check box. Scroll about half way down to where it says ‘OpenCl Platform’ and it should now have your GPU listed.
https://www.instagram.com/paul_corfield_abstract_realism/ [www.instagram.com]
User Avatar
Member
33 posts
Joined: 9月 2018
Offline
Thanks paulcorfield.
I've added to houdini.env file & seems to have fixed the issue (see updated copy of houdini.env below)


# Houdini Environment Settings
#
# The contents of this file are read into the environment
# at startup. They will override any existing entries in
# the environment.
#
# The syntax is one entry per line as follows:
# VAR = VALUE
#
# Values may be quoted
# VAR = “VALUE”
#
# Values may be empty
# VAR =
#

# Example:
#
# HOUDINI_NO_SPLASH = 1



HOUDINI_NVIDIA_OPTIX_DSO_PATH = C: /Users/…/Documents/houdini17.0\optix

HOUDINI_OCL_VENDOR = NVIDIA Corporation

HOUDINI_OCL_DEVICENUMBER = 0

I actually downloaded Nvidia optix the other day to see if that would help, which explains what was the last line of txt on the houdini.env file before I added the txt you provided below it. Not sure if having optix helped or not & not even sure if I needed to download or not.

I opened up the same file I got the message on the other day to test & no message so hoping that has fixed the issue. Thank you again. Legend.
The only devil I know is in the detail.
User Avatar
Member
45 posts
Joined: 3月 2017
Online
I tried this but it didn't work for me.

My houdini.env file reads:

#
# Houdini Environment Settings
#
# The contents of this file are read into the environment
# at startup. They will override any existing entries in
# the environment.
#
# The syntax is one entry per line as follows:
# VAR = VALUE
#
# Values may be quoted
# VAR = “VALUE”
#
# Values may be empty
# VAR =
#

# Example:
#
# HOUDINI_NO_SPLASH = 1


HOUDINI_DSO_ERROR = 2
PATH = “COctane_3.08.0.9/bin;CProgramData/Redshift/bin;$PATH”
HOUDINI_PATH = “COctane_3.08.0.9;CProgramData/Redshift/Plugins/Houdini/16.5.634;&”

HOUDINI_OCL_VENDOR = NVIDIA Corporation

HOUDINI_OCL_DEVICENUMBER = 0



but still get warning No OpenCL platform has the specified device type (HOUDINI_OCL_DEVICETYPE): GPU. Falling back to built-in CPU OpenCL driver.

I'm on Windows 10, Houdini 16.5.634, 2x 1080ti
User Avatar
Member
143 posts
Joined: 10月 2015
Offline
Hello I am on windows 10 and i have this problem since i installed the last Nvidia Driver
Houdini can't find anymore my GPU (nvidia 1070) for OpenCL like if i go in preference/misc/OpenCL
Reverting to the previous NVIDIA driver fixed the issue
of course one day or another i will have to update my Driver so i reported this issue as a bug to Sidefx
Maybe it's because of the new RTX stuff they implement in the Driver, i don't know….
But you could try this , it worked for me !

Ben
User Avatar
Member
17 posts
Joined: 2月 2017
Offline
Same issue here on H17, after installing the latest NVIDIA driver. H16.5 stayed unaffected. Rolling back the nvidia driver did not solved the issue.
User Avatar
Member
4 posts
Joined: 5月 2006
Offline
@SteveS_66 would you mind listing the nVidia driver version you are using?



SteveS_66
Thanks paulcorfield.
I've added to houdini.env file & seems to have fixed the issue (see updated copy of houdini.env below)


# Houdini Environment Settings
#
# The contents of this file are read into the environment
# at startup. They will override any existing entries in
# the environment.
#
# The syntax is one entry per line as follows:
# VAR = VALUE
#
# Values may be quoted
# VAR = “VALUE”
#
# Values may be empty
# VAR =
#

# Example:
#
# HOUDINI_NO_SPLASH = 1



HOUDINI_NVIDIA_OPTIX_DSO_PATH = C: /Users/…/Documents/houdini17.0\optix

HOUDINI_OCL_VENDOR = NVIDIA Corporation

HOUDINI_OCL_DEVICENUMBER = 0

I actually downloaded Nvidia optix the other day to see if that would help, which explains what was the last line of txt on the houdini.env file before I added the txt you provided below it. Not sure if having optix helped or not & not even sure if I needed to download or not.

I opened up the same file I got the message on the other day to test & no message so hoping that has fixed the issue. Thank you again. Legend.
User Avatar
Member
33 posts
Joined: 9月 2018
Offline
Currently using driver shown in attachments.
Edited by DevoStevo - 2018年12月29日 05:47:21

Attachments:
NvidiaDriverVer_181229.jpg (57.7 KB)
GeForceExp_DriverVer_181229.jpg (29.1 KB)

The only devil I know is in the detail.
User Avatar
Member
1 posts
Joined: 10月 2019
Offline
I can not solve the problem, does anyone help me? The version of my houdini is 18.5.462
User Avatar
Member
39 posts
Joined: 12月 2018
Offline
This question and the first solution provided by paulcorfield are still relevant. Thank you.
User Avatar
Member
2 posts
Joined: 7月 2016
Offline
I have same issue, but it is because I update my graphic card,

So if you have same problem with me,

Edit > Preferences > Miscellaneous > OpenCL Device

change to your new Card.

Attachments:
2022-09-05_142957.jpg (140.2 KB)

User Avatar
Member
1 posts
Joined: 9月 2022
Offline
BeanGuard
I have same issue, but it is because I update my graphic card,

So if you have same problem with me,

Edit > Preferences > Miscellaneous > OpenCL Device

change to your new Card.


This works for me. The dedicated GPU was not selected in the settings.
User Avatar
Member
20 posts
Joined: 2月 2017
Offline
Thanks a lot for those nice solutions.

Crystal Clear answer
User Avatar
Member
6 posts
Joined: 3月 2019
Offline
akash.singh
BeanGuard
I have same issue, but it is because I update my graphic card,

So if you have same problem with me,

Edit > Preferences > Miscellaneous > OpenCL Device

change to your new Card.


This works for me. The dedicated GPU was not selected in the settings.


this method worked for with RTX card Houdini 19.0
User Avatar
Member
934 posts
Joined: 4月 2008
Offline
I am having this issue on Fedora 38 after a fresh install of the OS, it was working fine before.
Am I missing something?
Edited by mzigaib - 2023年4月23日 17:15:55
https://vimeo.com/user2163076 [vimeo.com]
User Avatar
Member
934 posts
Joined: 4月 2008
Offline
Update:
I forgot to install cuda drivers, now it is working.
https://vimeo.com/user2163076 [vimeo.com]
  • Quick Links