Editable Curves work in other HDA but not when I make them

   2696   3   1
User Avatar
Member
14 posts
Joined: 8月 2022
Offline
So, I've been seeing that the editable curve workflow isn't supported anymore but that people can downgrade the curve node version do use it. If that workflow isn't supported, what replaces it?

After some fiddling, I can see editable curves (image 1) on assets from the Unity starter kit. https://www.sidefx.com/tutorials/unity-starter-kit/ [www.sidefx.com]
Those assets have the curve node listed in the editable nodes (image 2) and the HDA shows a Curves section with Houdini Engine in Unity which I presume is correlated. For some reason though if I add a curve as an editable node in my own HDA (image 3), I get no Curves section on the HDA in Unity (image 4). What am I missing?

The attached Tree HDA is from the Kit and works.
The sop_Hayes.dev.editable_curve_test.1.0 is mine and doesn't :/

Attachments:
1.png (217.2 KB)
2.png (87.2 KB)
3.png (86.4 KB)
4.png (21.4 KB)
HE_Tree.hda (66.6 KB)
sop_Hayes.dev.editable_curve_test.1.0.hda (8.1 KB)

User Avatar
Member
14 posts
Joined: 8月 2022
Offline
Well, I figured out a workaround. Basically, reverting the curve 2.0 node back to curve like I read on the forums isn't enough. Seems like there are some shenanigans going on behind the scenes. I can only get this to work by copying an old curve node from an old file, in this case, that unity starter kit Tree HDA. Doesn't matter if the settings are the same, a newly created and downgraded curve node won't work. Only an OG curve node will, at least on H19.5.303 unless I'm missing something.
User Avatar
Member
2 posts
Joined: 10月 2021
Offline
Was it ever mentioned what replaced the editable curve workflow? I can't imagine it not being supported with the only way to do it using the old version of the nodes. Can't find anything on it elsewhere online
User Avatar
Member
20 posts
Joined: 2月 2017
Offline
I have the same issue with Unity 2023.1 and H 19.5.
Does it's possible to report that to SideFX ?

Edit:

I downgraded an old Curve node that was from 16.5 and it works again now.
Adding a Curve Node directly from 19.5 doesn't work as it seems to be 2.0 curve node.
Edited by smoluck - 2023年8月21日 23:18:47
  • Quick Links