HoudiniEngine plugin prevents Arnold (mtoa.mll) starting

   1043   1   1
User Avatar
Member
5 posts
Joined: 3月 2019
Offline
I'm using Maya 2022, Houdini Engine v19.5.640/HE:5.0/API:7

If I load (enable) the houdiniEngine plug-in (houdiniEngine.mll) either by turning it on in the Plugin Manager window or by code
cmds.loadPlugin('houdiniEngine')
it works fine, but from that point onwards, the Arnold plug-in (mtoa.mll) will not start. Even if I disable the Houdini plug-in again, trying to launch the Arnold Plug-in always results in:

// Error: file: C:/Program Files/Autodesk/Maya2022/scripts/others/pluginWin.mel line 316: Unable to dynamically load : C:/Program Files/Autodesk/Arnold/maya2022/plug-ins/mtoa.mll
//
// Error: file: C:/Program Files/Autodesk/Maya2022/scripts/others/pluginWin.mel line 316: (mtoa) //

However, if I close and restart Maya the Arnold plug-in always starts fine every time, so long as I haven't started HoudiniEngine.mll. I've seen plenty of plug-ins not start due to missing dependencies and such, but never seen this kind of behaviour where plug-ins are clashing with, or impairing, each other.

If I start Arnold first and then HoudiniEngine it seems to work, but a) I'm not sure that's enough to convince me everything is fine there, and b) I really don't want to have to enforce Arnold to be enabled by default on startup for every user in the studio as a workaround.

Has anyone got any ideas what's happening here, or does anyone know of some way to debug the plug-in initialisation to diagnose what's clashing?
User Avatar
スタッフ
451 posts
Joined: 8月 2019
Offline
Hi Nathan, I was just made aware of this issue last week. My initial thought is that there is some library conflict here.

I'll look into it shortly.
  • Quick Links