camera motion blur on volumes not working properly or at all

   851   4   1
User Avatar
Member
16 posts
Joined: 2月 2018
Offline
Hello,

I am in Solaris and I was just playing around with camera motion blur (not velocity), and I cannot get it work with volumes such as explosions for instance. I have a render geometry settings lop to enable motion blur for the volume primitive and I have a cache lop as well which is set to manual and I have exaggerated the open and close shutter values and made sure that my samples are sufficiently high enough. But, for some reason it is not working with volumes. Can someone who maybe has more experience with this maybe let me know what I am doing wrong? I am attaching the example hip file I am working on.

Image Not Found
Edited by damon_c_john - 2024年1月1日 23:26:49

Attachments:
example.hipnc (3.9 MB)

User Avatar
Member
8619 posts
Joined: 7月 2007
Offline
- your camera is not animated so there will be no camera motion blur
- and volume can't have deformation motion blur so to get the motion from your explosion movement you have to use Velocity motion blur
- Shutter Open/Close on Cache LOP is only for sampling settings to specify cache range and samples, but to actually open the shutter more you have to do that on the camera, ideally keep those settings in sync or just set the caching directly on Camera LOP if that's the only one you care about caching (it'd make sense only if it's animated though)
Edited by tamte - 2024年1月2日 01:16:26

Attachments:
example_mod.hipnc (1.8 MB)

Tomas Slancik
FX Supervisor
Method Studios, NY
User Avatar
Member
16 posts
Joined: 2月 2018
Offline
I see! Thanks for the reply. Those examples really help!
User Avatar
Member
27 posts
Joined: 7月 2005
Offline
Ive just been losing my mind trying to get this to work, and what it came down to was Scene Import vs SOP Import. I opted for the Scene import as my FX had some object level transforms. Why does Scene import not support volume motion blur? Is there an attribute or setting on scene import I need to enable?
User Avatar
Member
238 posts
Joined: 3月 2013
Offline
Scene import is doing a brute force load and it's trying to use your existing OBJ level containers settings.
The objects coming in have a higher opinion than any render settings/geo settings so that is why you see no change.

You need to enable velocity blur on the OBJ level containers you need blur on, as if they were going to mantra.
Part of the reason that the whole notion of pulling in data via SOPs Vs writing out USD and loading properly
is just bad news in general. I get it's a quick way to render, but you pay a price in other areas.

So just to be clear, the Scene Import will pull stuff in with whatever values are in OBJ and they have stronger
opinions.
I'm not lying, I'm writing fiction with my mouth.
  • Quick Links