Jim Bachalo

art3mis

About Me

Expertise
Developer
Location
Canada
Website

Connect

Recent Forum Posts

FLIP failure Dec. 11, 2019, 9:08 p.m.

Have a sudden loss of my FLIP particles for no apparent reason.
Through trial and error though I think I am getting closer to figuring out why.

In 2 tests with the exact same settings, the only thing I changed was the Collision Separation override on my FLIP Object.

When it was set to .5 * Particle Separation the simulation fails at around frame 100.(the particles rapidly drain away)

When it was set to .25 * Particle Separation the simulation fails on or around frame 40.

So my thinking possibly memory related??
I checked and OpenCL is NOT enabled on my Solver.


What else could be causing this?

Creating collision VDBs from animated geometry Dec. 11, 2019, 9:51 a.m.

Question about proper way to animate your geometry when using for collision.

If you animate some geometry and then use an Object Merge to bring this geometry inside another geo where you create your collisions (using either Collision SOP or VDB From Polygons, does this mean in essence you are recreating your collision VDBs on every frame?

Should you instead animate your collision VDB(s) AFTER they are created?

AFAIK the important thing is that your collision VDBs contain correct velocity values.

Proper scale for FLIP Dec. 10, 2019, 3:25 p.m.

So this has been mentioned in a few other threads but need some guidelines.

My understanding is that FLIP has issues (unstable, flickering, collision, etc) for “small” scale simulations. By that I assume means anything under roughly a metre in largest dimension.

What are some suggested starting points for scaling up your simulation for FLIP if its say, roughly a foot or so in diameter.

3X? 10 X?

And what about speed to compensate. If you increase the scale 3X do you also need to speed it up 3x as well?

There is also Spatial Scale on Solver and was wondering as a first step if i should try reducing to say .1 before I do anything else?