SOP solver object mask confusion

   4562   3   1
User Avatar
Member
65 posts
Joined: Nov. 2013
Offline
Hi,

I have three objects in an packed RBD DOP sim merged and pugged into a multi solver. I have a SOP solver connected. Inside the SOP Solver, on the dopimport node, the default expression for the “Object mask” is only visually bringing in one of the objects once inside the SOP solver. Essentially, inside the SOP solver I can only see Object 1. However, outside in the main DOP, I see Object 1 2 and 3, and everything else I would expect to see.

Inside The SOP solver, I'm transferring some velocities to Object 1 for an “explosion”.

The spread sheet only shows the point data for Object 1. Not 2 or 3.

Object 2 is not supposed to get any of the transferred velocities. However, outside in DOPs, it is getting them when the sim is played.

Middle clicking the default stamp expression in the dop import node in the sop solver shows just a “1” in the field.

The object mask doesn't seem to be showing the allowing or showing the data for object 2 or 3.

I've tried grouping them in SOPS and trying to remove them from the velocity transfer, however I get a warning in the SOP Solver saying the group I'm trying to use to remove Object 2 from the velocity attribute transfer, does not exist.

The object transferring the velocities is big and does overlap Object 1 and 2 in size. So it's not wholly unexpected that the velocities are being transferred to both objects. However, I can say, “Hey! Leave Object 2 alone” because Object 2's data seems to be masked.

My theory is that the stamp expression for the object mask is masking out the data for Object 2 and 3 so I can't see it or manipulated, but is still processing it and giving it velocity.

Anyone know what I'm talking about?

I'm at work so I can't send a hip.
User Avatar
Member
471 posts
Joined: Nov. 2013
Offline
Greeting.
It is best if you put your HIP file.
If you want to have all objects in scene view just turn the icon to not following selection at the top right of the scene view.
So when you dive inside SOP solver all geometry are available in scene view.
Another approach is set the object mask to * and turn off Do Not Trigger Simulation.
User Avatar
Member
102 posts
Joined: March 2013
Offline
Hi Hibatchi,

Not sure your question. If you want to apply something only on Obj1, you can use “switch” sop inside sopsolver and write:
ch(“../dop_geometry/objpattern”) == $OBJID(witch id you want to keep)
then only Obj1 will affected.

You can check the file

Attachments:
sopsolver_switch.hipnc (273.7 KB)

User Avatar
Member
1 posts
Joined: Oct. 2013
Offline
Thank you very mush igou,
I had a similar problem. Your reply and the sample file is very helpful!
  • Quick Links