Rebuild Problems

   2137   3   0
User Avatar
Member
2 posts
Joined: April 2016
Offline
I'm using Unity 5.6.2 and the production build of Houdini Indie.
Digital assets used in a Unity scene are not being retained when rebuilt. If I rebuild, save the scene and reopen it, it loads the previous version of the asset. It only retains if I also change a parameter in the asset.
It is also not rebuilding the assets when the scene is loaded. If I save a change to the digital asset from Houdini and reload the Unity scene, none of them are updated.
User Avatar
Member
571 posts
Joined: May 2017
Offline
I believe it is by design that an asset is not automatically rebuilt when loading a scene after it has been changed in Houdini. Enabling this behaviour might cause unnecessary updates to an HDA already in a scene. It makes sense to allow the user to manually rebuild if they want it.

As for your first issue where an asset was not retaining its rebuilt state after saving and loading, that is indeed a bug. Good catch. If you have Unity 5.3 or newer, I just put in a fix for it that should be available in tomorrow's daily build.

If you are unable to update to our daily builds, I can suggest a quick fix that you can apply locally. Which version of Unity are you using?
User Avatar
Member
2 posts
Joined: April 2016
Offline
I mentioned in the start of my post. Unity 5.6.2
It would be really useful, if not vital, to have a rebuild all and/or auto rebuild function. I intend to use many copies of many digital assets in my scenes, and it would be grueling to have to click and rebuild on every single one every time I make an update to each digital asset. If I'm missing something or there's a workaround, please let me know.
Thank you for your help. I'll check into daily builds soon.
User Avatar
Member
571 posts
Joined: May 2017
Offline
Good suggestions on the rebuild all and auto-rebuild. Agreed on the improved workflow. This is something I'll add to our list in future updates. Thanks.
  • Quick Links