[Solved] OpenCL setup for 17?

   8938   8   3
User Avatar
Member
15 posts
Joined: March 2014
Offline
I have recent Nvidia drivers (with CUDA 9.2) installed and working for other applications.

Is there something else I need to install to get OpenCL working for Houdini 17? I thought it all came with the base driver and/or the CUDA stuff.

Or are there ENV vars I have to manually set up to explain it to H?

I looked through the documentation without any luck.

Help->About Houdini pops up a console window saying:

Unable to load HFS OpenCL platform.
OpenCL Exception: €EË{ (-1)

And the About, Show Details says “No OpenCL Provider” in it.
Edited by Zoot - Oct. 15, 2018 22:42:40
User Avatar
Member
15 posts
Joined: March 2014
Offline
Still no luck with OpenCL. I upgraded from 39x to 416 Nvidia drivers for my 1060 without any effect.

I have various ENV variables in Windows 10 related to the CUDA toolkits being used for Tensorflow and Pytorch, and I suspect perhaps that or the CUDA version(s) installed are preventing H from seeing what it needs.

PATH=C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.0\bin;C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.0\libnvvp;C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.1\bin;C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.1\libnvvp;C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v8.0\bin;C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v8.0\libnvvp;C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\cuda\bin;"

No Configured OpenCL Device

Environment:

CUDA_PATH C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.0
CUDA_PATH_V8_0 C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v8.0
CUDA_PATH_V9_0 C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.0
CUDA_PATH_V9_1 C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.1

NVCUDASAMPLES8_0_ROOT C:\ProgramData\NVIDIA Corporation\CUDA Samples\v8.0
NVCUDASAMPLES9_0_ROOT C:\ProgramData\NVIDIA Corporation\CUDA Samples\v9.0
NVCUDASAMPLES9_1_ROOT C:\ProgramData\NVIDIA Corporation\CUDA Samples\v9.1
NVCUDASAMPLES_ROOT C:\ProgramData\NVIDIA Corporation\CUDA Samples\v9.0
NVTOOLSEXT_PATH C:\Program Files\NVIDIA Corporation\NvToolsExt\
User Avatar
Member
4 posts
Joined: Feb. 2016
Offline
I had to put this in my env file to get OpenCl working in H17

HOUDINI_OCL_VENDOR = NVIDIA Corporation

HOUDINI_OCL_DEVICENUMBER = 0
https://www.instagram.com/paul_corfield_abstract_realism/ [www.instagram.com]
User Avatar
Member
9 posts
Joined: Aug. 2014
Offline
Zoot
Still no luck with OpenCL. I upgraded from 39x to 416 Nvidia drivers for my 1060 without any effect.

I have various ENV variables in Windows 10 related to the CUDA toolkits being used for Tensorflow and Pytorch, and I suspect perhaps that or the CUDA version(s) installed are preventing H from seeing what it needs.

PATH=C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.0\bin;C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.0\libnvvp;C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.1\bin;C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.1\libnvvp;C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v8.0\bin;C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v8.0\libnvvp;C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\cuda\bin;"

No Configured OpenCL Device

Environment:

CUDA_PATH C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.0
CUDA_PATH_V8_0 C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v8.0
CUDA_PATH_V9_0 C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.0
CUDA_PATH_V9_1 C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.1

NVCUDASAMPLES8_0_ROOT C:\ProgramData\NVIDIA Corporation\CUDA Samples\v8.0
NVCUDASAMPLES9_0_ROOT C:\ProgramData\NVIDIA Corporation\CUDA Samples\v9.0
NVCUDASAMPLES9_1_ROOT C:\ProgramData\NVIDIA Corporation\CUDA Samples\v9.1
NVCUDASAMPLES_ROOT C:\ProgramData\NVIDIA Corporation\CUDA Samples\v9.0
NVTOOLSEXT_PATH C:\Program Files\NVIDIA Corporation\NvToolsExt\


Not really sure whats happening, as openCL just works out of the box for me, but it isnt related to CUDA, cuda is its own thing, openCL is an open alternative. All i can suggest is a clean uninstall of the driver and re-install?
User Avatar
Member
15 posts
Joined: March 2014
Offline
I've been working with support and trying different things with no luck so far.

I'm suspicious that it's related to the fact that this system has both Intel and Nvidia OpenCL, and perhaps Houdini has an issue such as that described in:

https://stackoverflow.com/questions/19140989/how-to-remove-cl-invalid-platform-error-in-opencl-code [stackoverflow.com]

Anyone running H17 successfully on a hybrid system with both Intel and Nvidia graphics?

I get -32 (invalid platform) or -33 (invalid device) generally in the console when it tries to initialize OpenCL. I can force it back to CPU only and that is successful using:

HOUDINI_OCL_DEVICETYPE=CPU
HOUDINI_USE_HFS_OCL=0

But every other permutation fails.
User Avatar
Member
15 posts
Joined: March 2014
Offline
Ok, I managed to get it working (yay).

The problem was that there's a configuration for your choice of OpenCL device squirreled away at Edit->Preferences->Miscellaneous, and it was defaulting to the first OpenCL provider which was the Intel 630 Integrated graphics.

Combined with this, all the environment variables support suggested to override the behavior were apparently insufficient to override that Misc setting, and setting the Misc selection works when the env vars were not. So the complete solution was:

1) Set Miscellaneous preferences OpenCL to GPU and the appropriate Nvidia device.
2) Remove any and all extra OCL related environment variables from Houdini.env EXCEPT for:

HOUDINI_USE_HFS_OCL=0

which is still needed at least on my system to get it to load correctly.

Now OpenCL initializes successfully and vellum is successfully heating up the GPU. Woot.
User Avatar
Member
1 posts
Joined: Jan. 2017
Offline
Hi, I have the same issue.
I'm working on a Intel/NVIDIA system and as I installed H 17 I get the error related to the OpenCL. I found in Preferences -> Miscellaneous the OpenCl tab, but it seems like houdini can't see my NVIDIA GPU, since the only one I can choose is the Intel one.

How can I make Houdini recognize the NVIDIA GPU?
Annalisa Benedetti

Junior VFX Artist - 3D Generalist
User Avatar
Member
2 posts
Joined: July 2015
Offline
Revert Drivers per https://www.sidefx.com/forum/topic/59264/ [www.sidefx.com]

UPDATE: It is indeed the drivers! SOLVED…again
Edited by Michael Trainor - Nov. 16, 2018 03:29:55
User Avatar
Member
8 posts
Joined: Jan. 2018
Offline
Zoot
Ok, I managed to get it working (yay).

The problem was that there's a configuration for your choice of OpenCL device squirreled away at Edit->Preferences->Miscellaneous, and it was defaulting to the first OpenCL provider which was the Intel 630 Integrated graphics.

Combined with this, all the environment variables support suggested to override the behavior were apparently insufficient to override that Misc setting, and setting the Misc selection works when the env vars were not. So the complete solution was:

1) Set Miscellaneous preferences OpenCL to GPU and the appropriate Nvidia device.
2) Remove any and all extra OCL related environment variables from Houdini.env EXCEPT for:

HOUDINI_USE_HFS_OCL=0

which is still needed at least on my system to get it to load correctly.

Now OpenCL initializes successfully and vellum is successfully heating up the GPU. Woot.


just got this issue on 17.5, with my laptop, the edit>preferences>miscellaneous fixed my issue. thank you!
  • Quick Links