Houdini 20 HtoA ACES/OCIO troubleshooting.

   595   2   3
User Avatar
Member
2 posts
Joined: Jan. 2022
Offline
Hello,

I'm having trouble getting ACES/OCIO to work properly in Houdini 20 when rending with Arnold. I have followed the workflow outlined in the Autodesk documentation [help.autodesk.com] and some of the options available do not align with what I'm seeing in Houdini and when compositing in After Effects.

First, I've gone ahead and pointed by OCIO package to reference the ocio.config that ships with Arnold.

Following along with the ACES workflow documentation, I'm attempting to change the color space settings in the Solaris Render Product Node and the Render Settings Node but oddly enough "ACES" is not an available option for the "Output color family" in the Render Product Node or the "Rendering Color Family" in the Render Settings Node. Instead, I have the option of "Scene-linear" or "Utility." Selecting "Scene-linear" allows me to choose "ACEScg" in the adjacent drop-down on both nodes.

Furthermore, in the Solaris render view, I have different options in the OCIO display and view options than are shown in the ACES workflow documentation.

Upon rendering, I have those same options in Mplay. Then, when I bring the EXR into After effects for rendering, the colors are over-saturated compared to the soalris render view and the Mplay view. The color settings in After effects are:

Color Engine: OCIO

OCIO Configuration: Aces 1.3 CG v1.0

Bit Depth: 32 bits per channel (float)

Working color space: scene_linear:ACEScg
Display color space: sRGB - Display/ACES 1.0 - SDR Video

Does anyone know why I'm not seeing the color spaces in the Render Product and Render Settings nodes? Is the saturation shift in After Effects due to a OCIO setting mismatch?

Thanks!

Any help would be greatly appreciated.
Edited by BSwarth - Feb. 6, 2024 16:49:39

Attachments:
Screenshot 2024-02-06 at 12.27.39PM.png (324.3 KB)
Screenshot 2024-02-06 at 12.55.47PM.png (159.0 KB)
Screenshot 2024-02-06 at 12.56.44PM.png (168.7 KB)
Screenshot 2024-02-06 at 12.56.19PM.png (2.9 MB)
Screenshot 2024-02-06 at 12.56.25PM.png (2.2 MB)
Screenshot 2024-02-06 at 1.11.23PM.png (579.8 KB)

User Avatar
Member
4 posts
Joined: April 2023
Online
Hi, I am using external ocio.config file v1.2 from https://github.com/colour-science/OpenColorIO-Configs/tree/feature/aces-1.2-config [github.com]
To set it up add this line to end of houdini.env file and replace the path:
OCIO = "C:/3D/Assets/Aces/aces_1.2/config.ocio"

In render settings node I use ACES and ACES-ACEScg which are there by default. Render view and mplay are set to ACES & sRGB.

Can't help with AE part since I use Davinci Resolve. In Resolve I use same OCIO 1.2 file to convert exr images from ACES-CG color space to sRGB and it works like a charm.

Attachments:
render_view_mplay.png (11.6 KB)
render_settings.png (15.4 KB)

User Avatar
Member
9 posts
Joined: Jan. 2024
Offline
Just to confirm whether you're seeing the same behavior as me. I'm on Houdini (Core) 20.0.547 with HtoA 6.2.5.1.

1. Setting these Rendering Color Family and Narrow Color Family on the Arnold Render Settings node instead of the Render Settings node does not work. It always sets the value as "0" as opposed to the selected value.

2. A Custom OCIO config is ONLY loaded when these properties are set on the Render Settings prim that is being used. So e.g. specifying the color spaces for textures when looking through Arnold viewer in the scene above the Render Settings prim or with the "Viewport Settings" display options does not show the correct colors. (Make sure to "Restart Render" for the view so it initializes the active settings). If you enable higher verbosity of the Arnold Render Settings you can see it'll always load the HtoA built-in OCIO instead of the one set from the OCIO env var.

This is also the reason why the Color Space doesn't really work if you don't set those properties (which to me, is very odd default behavior, it should default to the default roles in the OCIO config defined by the `OCIO` env var if not overridden on the Render Settings prim). If that were the case - you wouldn't need to explicitly set these on the Render Settings prim as these are the default values for your OCIO config.

3. When in Render Settings setting "Auto-Generate TX" to disabled and "Use Existing TX" to disabled then the color space conversions in the renderer will report warnings in the logs like: ` unable to convert from color space "ACES - ACEScg", ignoring color transform (filename = "c:\path\to\file.exr")`.
Actually no - this last one was only if the OCIO config failed to load due to any of the issues of 1) or 2).
Edited by colorbleed - Feb. 8, 2024 19:50:10
  • Quick Links