White Water RAM usage

   9420   17   4
User Avatar
Member
16 posts
Joined: 7月 2018
Offline
Hello there,

I've an annoying problem. I'm making a whiter water simulation. I noticed that if I enabled “density control” Houdini fills the ram and after several frames it crashes. If I disable it everything works fine.

I've read lot of posts regarding this problem. Here for example [forums.odforce.net]. It seems to be a Win10 issue, but no one posted a solution for that.

Is there definitely a way avoid this problem? Does MAC users have the same issue?

Houdini 17.5/Windows 10
User Avatar
Member
16 posts
Joined: 7月 2018
Offline
Really? No one has a solution for that?
User Avatar
Member
4189 posts
Joined: 6月 2012
Offline
Mac and Linux wont have this issue.
User Avatar
Member
16 posts
Joined: 7月 2018
Offline
So annoying. The problem is I have a FX license on windows at work and Apprentice Version on Mac at home.

In case, Is it possible to keep the same FX license on dual boot Windows/Linux?

Otherwise, can I cache through filecache node with Apprentice version?

Are they going to fix this problem on Windows on 18 Version?
Edited by mois23 - 2019年11月6日 03:02:12
User Avatar
Member
4189 posts
Joined: 6月 2012
Offline
dug this gemstone up for you:

On Windows, the use of the tbbmalloc_proxy library may now be disabled by setting the environment variable TBBMALLOC_PROXY_ENABLE to 0 (defaults to 1). Disabling tbbmalloc_proxy switches Houdini to use the system allocator which is about 1.8x slower under high thread contention but it allows better memory usage so that some simulations can be completed on machines with insufficient RAM under Windows.

Give it a whirl!
User Avatar
Member
16 posts
Joined: 7月 2018
Offline
Hey goat. Thank you for your reply.

An update..

I tried to make same simulation on my Mac. RAM fills completely as well, but at least Houdini doesn’t crash. The problem is that whitewater uses all my 64GB of RAM just for 700.000 particles if I enable density control (I really need it because of the natural look of the foam).

Maybe the problem is that I’m making flip book for seeing the result? Do you think I can save lot of memory with command line?

In the meantime I’ll try your tip on Windows.

Fingers crossed.
Edited by mois23 - 2019年11月8日 02:58:42
User Avatar
Member
4189 posts
Joined: 6月 2012
Offline
Dug a bit and did a test. Turning off OpenCL, on whitewatersolver1 inwhitewater_sim, reduced memory usage from 20GB to 8GB.

Hit up SideFx too as that seems very crazy.
User Avatar
Member
16 posts
Joined: 7月 2018
Offline
goat
Dug a bit and did a test. Turning off OpenCL, on whitewatersolver1 inwhitewater_sim, reduced memory usage from 20GB to 8GB.

Hit up SideFx too as that seems very crazy.


Interesting! I'll make same test on windows and mac during the weekend. Hope to see the same result.

Thank you so much for your help!
User Avatar
Member
16 posts
Joined: 7月 2018
Offline
An update.

I made a test on Windows. Enabling Density Control always fills RAM. Even switching off OpenCL. I even tried to cache out through command line and disabling TBBMALLOC_PROXY. Houdini uses averagely 58GB of RAM for 7 Million particles simulation (White Water Scale: 0.01).

Without density control I can push White Water Scale to 0.007 and it can simulate more than 20mln particles using just 40GB of RAM.

This is insane. I know that it's Windows fault. But this is unacceptable, anyway.

I've attached my project file..

Attachments:
Ocean_Guided_Ship.hip (4.8 MB)

User Avatar
Member
9 posts
Joined: 3月 2017
Offline
Hello i just find a posible solution for this bug just enter inside the solver there is a wrangle for density control in the bottom is a drop menu when you can select between 32 bits 64 bits and auto
i put 32 bits and is working much better even increased the resolution and consumes less ram
User Avatar
Member
31 posts
Joined: 6月 2010
Offline
jpdecristo
Hello i just find a posible solution for this bug just enter inside the solver there is a wrangle for density control in the bottom is a drop menu when you can select between 32 bits 64 bits and auto
i put 32 bits and is working much better even increased the resolution and consumes less ram
Hi, can you share printscreen where exactly that wrangle is.
Thanks!
User Avatar
Member
268 posts
Joined: 7月 2005
Offline
Poked around whitewater solver with performance monitor; looks like neighbour creation and killing dead sopsolvers are eating up memory on win10.

Fix that worked for me:

- Edit->Preferences->Object and Geometry->Sop Cache->Cull Level to 4 (this will unload nodes that have flag on)
- Go to /obj/whitewater_sim/whitewatersolver1/position_based_fluid/create_neighborhoods
select all nodes and RMB->Flags->Unload (this sets the actual unload flag you should see little trashcan icon on all nodes)
- bypass /obj/whitewater_sim/whitewatersolver1/kill sopsolver node
this is one is a headscratcher??? setting all nodes to unload had no effect; tried moving deletion into wrangle and bypassing blast sop no effect as well.. only way to stop it from chugging memory was to bypass it.

With above changes I was able to get similar memory numbers on win10 as I was getting on ubuntu 20.04.
Edited by AdamJ - 2020年6月27日 21:11:06
User Avatar
Member
76 posts
Joined: 1月 2009
Offline
Hi

Seems like this bug is still around. Following AdamJs steps able to keep the memory use to 80% of 64gb and sim 10 million. Its strange that it hasnt been addressed yet some of the posts I have seen with this issue, go back to version 17 and beyond.
User Avatar
Member
5 posts
Joined: 1月 2015
Offline
Hi all,

I'm on 18.0.566 and am maxing out as well (64GB with a 2990WX for crying out loud). I'll do some testing with the above mentioned suggestions and will report back .

I had the same exact issue on H15 btw… tech support couldn't figure it out back then. it's a shame to see that it's still there
Edited by Jebbel_Jebbel - 2020年10月2日 04:47:02
User Avatar
Member
5 posts
Joined: 1月 2015
Offline
AdamJ
Poked around whitewater solver with performance monitor; looks like neighbour creation and killing dead sopsolvers are eating up memory on win10.

Fix that worked for me:

- Edit->Preferences->Object and Geometry->Sop Cache->Cull Level to 4 (this will unload nodes that have flag on)
- Go to /obj/whitewater_sim/whitewatersolver1/position_based_fluid/create_neighborhoods
select all nodes and RMB->Flags->Unload (this sets the actual unload flag you should see little trashcan icon on all nodes)
- bypass /obj/whitewater_sim/whitewatersolver1/kill sopsolver node
this is one is a headscratcher??? setting all nodes to unload had no effect; tried moving deletion into wrangle and bypassing blast sop no effect as well.. only way to stop it from chugging memory was to bypass it.

With above changes I was able to get similar memory numbers on win10 as I was getting on ubuntu 20.04.

btw..I'd be interested in your thought process here (read: how the hell did you figure this out?!)
User Avatar
Member
31 posts
Joined: 2月 2018
Offline
jpdecristo
wrangle
Hi,
can you show where is the node, which I found only this at not very "bottom" like you mention. Thank you

Attachments:
density-control.JPG (149.1 KB)

User Avatar
Member
76 posts
Joined: 8月 2018
Offline
AdamJ
Poked around whitewater solver with performance monitor; looks like neighbour creation and killing dead sopsolvers are eating up memory on win10.

Fix that worked for me:

- Edit->Preferences->Object and Geometry->Sop Cache->Cull Level to 4 (this will unload nodes that have flag on)
- Go to /obj/whitewater_sim/whitewatersolver1/position_based_fluid/create_neighborhoods
select all nodes and RMB->Flags->Unload (this sets the actual unload flag you should see little trashcan icon on all nodes)
- bypass /obj/whitewater_sim/whitewatersolver1/kill sopsolver node
this is one is a headscratcher??? setting all nodes to unload had no effect; tried moving deletion into wrangle and bypassing blast sop no effect as well.. only way to stop it from chugging memory was to bypass it.

With above changes I was able to get similar memory numbers on win10 as I was getting on ubuntu 20.04.


Thx! this worked! i have done my white water sims in linux because this problem.
User Avatar
Member
56 posts
Joined: 3月 2022
Offline
So glad I found this! I've spent weeks tweaking settings trying to balance the amount of particles and RAM usage.... Hope it works for me and I can bulk out my WW.


Thanks!
  • Quick Links