FLIP fluid without initial movement

   7411   10   2
User Avatar
Member
109 posts
Joined: June 2008
Offline
Hi!

If you look the attached file… I have a fluid surface which is surrounded by a static object - acting as a tank, and a sphere that is falling into fluid.

The problem is that the fluid surface starts moving before the sphere hits it.

What is the “correct” way to stop this happening?

Attachments:
test.hipnc (1.3 MB)

User Avatar
Member
166 posts
Joined: March 2013
Offline
What is happening is that the particles is reacting to the gravity. That in itself isn't a problem, but the collision volume for your tank isn't a tight fit - so naturally the water will fill out the empty space. You'd have to increase the resolution on your collision volume, or turn off “Use Volume Based Collision Detection” which nets you very accurate collisions quickly. I've been having some problems with that lately though, whenever I turn it off it literally rains particles out of nowhere - so I wasn't going to recommend it at first, but incase it works properly for you, it is probably what you want to do.
User Avatar
Member
109 posts
Joined: June 2008
Offline
Increasing the Uniform Divisions in geo_tank Static object to 200 does not seem to fix it - there is still movement. But unchecking the Use Volume Based Collision Detection works a bit better… but the surface of the fluid seems to “sink”
User Avatar
Member
443 posts
Joined: Sept. 2012
Offline
Dive inside fluidtank_initial node, under Ocean Spectrum set Wind Speed and Wave Amplitude Scale to 0.
User Avatar
Member
109 posts
Joined: June 2008
Offline
“luidtank_initial”? Do you mean that i have to create scene that is using Ocean? Im unable to find that node from my scene
User Avatar
Member
36 posts
Joined: Oct. 2011
Offline
Hi, KiLa, I think the problem is your fluid is a bit higher than your container, so the fluid will spill in the beginning of the simulation.

I've translated the fluid a bit lower than the container, is this what your want?

Attachments:
test_hanton.hipnc (1.3 MB)

User Avatar
Staff
818 posts
Joined: July 2006
Offline
Hanton's suggestion is a good one. Also you'll see more accurate sims with less erroneous movement at higher resolutions.

Finally, we recently discovered a bug in the way the FLIP solver does velocity extrapolation around collisions, which is what's causing those small “ghost” velocities around the bottom of the container. We're currently testing a fix in the development build, but are planning on backporting to 12.5 in the near future.
User Avatar
Member
109 posts
Joined: June 2008
Offline
Thx guys!

So if i want a motionless fluid surface AND a surrounding area that are on the same level, i need two different geos? One that is used when rendering and one that is used when simulating/
User Avatar
Member
166 posts
Joined: March 2013
Offline
johner
Finally, we recently discovered a bug in the way the FLIP solver does velocity extrapolation around collisions, which is what's causing those small “ghost” velocities around the bottom of the container. We're currently testing a fix in the development build, but are planning on backporting to 12.5 in the near future.
Oh that explains it, I could not wrap my head around why it was doing that. Please keep us posted!

Also, is this bug related to the strange things that happens when you turn off “Use Volume Based Collision Detection”? It has worked fine before, but now when I use it flip particles spawn out of thin air and rains down. I thought it was something else causing it before, but now I'm not so sure. You can see an example of this towards the end of this video: https://vimeo.com/70735913 [vimeo.com]
User Avatar
Staff
818 posts
Joined: July 2006
Offline
Skybar
johner
Finally, we recently discovered a bug in the way the FLIP solver does velocity extrapolation around collisions, which is what's causing those small “ghost” velocities around the bottom of the container. We're currently testing a fix in the development build, but are planning on backporting to 12.5 in the near future.
Oh that explains it, I could not wrap my head around why it was doing that. Please keep us posted!

This fix has finally been backported to 12.5 and should be available in tomorrow's build:

Journal entry
Fixed a long standing bug in the FLIP Solver that caused phantom velocities
along the bottom of curved collision containers such as bowls or cups.
There is a new parameter on the Solver tab to control the velocity
Extrapolation Mode, with a default of Normal that selects the new, more
accurate extrapolation method.

This change affects velocity extrapolation around collisions and at
the liquid surface, and should provide improved, but likely different
simulation behavior. Therefore the other option for Extrapolation Mode is
Compatibility, which retains the previous extrapolation behavior for
backwards compatability.

Also, is this bug related to the strange things that happens when you turn off “Use Volume Based Collision Detection”? It has worked fine before, but now when I use it flip particles spawn out of thin air and rains down. I thought it was something else causing it before, but now I'm not so sure. You can see an example of this towards the end of this video: https://vimeo.com/70735913 [vimeo.com]

Hmm, I think you've always needed “Use Volume Based Collision Detection” enabled. FLIP needs to see collisions as SDF's to do a proper pressure solve.
User Avatar
Member
166 posts
Joined: March 2013
Offline
johner
This fix has finally been backported to 12.5 and should be available in tomorrow's build:
Great! Thanks!

Hmm, I think you've always needed “Use Volume Based Collision Detection” enabled. FLIP needs to see collisions as SDF's to do a proper pressure solve.
Hmm yeah that could be it actually. I've been using it before with FLIP mainly because it gets you very accurate collisions very quick, but I guess it was the first time I used it while working with viscous FLIP without thinking about it. I've started calculating my collision volumes with VDB now though, which is quite fast as well and I like it. But this is good to know, thanks!
  • Quick Links