H12.5 viewport displays geometry that it's NOT SUPPOSED TO!

   25456   31   4
User Avatar
Member
4189 posts
Joined: June 2012
Offline
I have a reproducible steps: please test

0. New Houdini session. Set the Viewport to “Hide Other Objects”
1. Create any Sop i.e. Grid and dive inside to Geometry Level
2. Append SopSolver & set display flag to solver
3. dive inside Solver
4. Move Current time indicator to another frame i.e. 64 - the Dop Import node “Prev_frame” should show an error.
5 Jump back to Scene level
6. Change Viewport from“ Hide Other Objects” to “Show All Objects ”
7. Toggle Display button - geo should now be stuck

Edit: Bug report submitted to Support. Further testing shows this to match all the issues, such as closing and reopening Houdini fixes it , and, opening a new scene pane fixes it.
User Avatar
Member
4189 posts
Joined: June 2012
Offline
Attached is a screen recording from a new Houdini session that shows the viewport getting stuck. This follows the steps in the above post.

Edit: fix download zip

Attachments:
StuckViewport2 - Wi-Fi.m4v.zip (3.2 MB)

User Avatar
Member
258 posts
Joined: July 2006
Offline
same issue, it just burns in to the viewport but it burns in 3D not stuck from a single angle. work machine so dont remember details centos 6 h12.5 gtx560ti
dont remember the driver number
Head of CG @ MPC
CG Supervisor/ Sr. FX TD /
https://gumroad.com/timvfx [gumroad.com]
www.timucinozger.com
User Avatar
Staff
5139 posts
Joined: July 2005
Offline
Thanks for the steps. I'll take a look when I'm back in the office in two weeks.

In the meantime, if anyone else has a different set of steps to end up in this state, please post them as well. The general nature of this bug suggests that the Hide/Ghost setting probably isn't the main culprit, though fixing the above may shed light on the general problem.
User Avatar
Member
10 posts
Joined: Sept. 2008
Offline
We've been experiencing this rather frustruting problem too, and it seems to stem from the “Delay Inactive Viewport Redraws” setting.

After disabling that setting (Edit -> Perferences -> 3D Viewports -> Delay Inactive Viewport Redraws) the problem seemed to have gone away on this side.

CheerZ,
Van Aarde.
User Avatar
Member
8 posts
Joined: Dec. 2011
Offline
I just tried this and it still seems to give the issue. For me the ghosting occurs most when i switch between my networks from the drop down at the top of the viewport.

Once this occurs, if i switch to my render view tab and then back to my scene view it refreshes and 3d ghost disappers.

Like others although this happens often its not something u can reproduce by following some steps as it doesnt always happen

Currently using CentOS, Houdini 12.5.427

nanocell
We've been experiencing this rather frustruting problem too, and it seems to stem from the “Delay Inactive Viewport Redraws” setting.

After disabling that setting (Edit -> Perferences -> 3D Viewports -> Delay Inactive Viewport Redraws) the problem seemed to have gone away on this side.

CheerZ,
Van Aarde.
Saqib

Just take it one OP at a time and you will find inner peace.
User Avatar
Member
4189 posts
Joined: June 2012
Offline
cool as - thanks all. I hear this bug is meant to be now fixed in Houdini 13 and might be backported if it can be. I'm now sure what the exact bug was, so I don't know if these latest issues are the same one.
User Avatar
Member
14 posts
Joined: Oct. 2011
Offline
nanocell
We've been experiencing this rather frustruting problem too, and it seems to stem from the “Delay Inactive Viewport Redraws” setting.

After disabling that setting (Edit -> Perferences -> 3D Viewports -> Delay Inactive Viewport Redraws) the problem seemed to have gone away on this side.

CheerZ,
Van Aarde.

I was wondering if it was this setting. I also noticed that toggling the Scene Renderer to H11 and back to OpenGL 3.2 got rid of it.
User Avatar
Member
76 posts
Joined: Sept. 2011
Online
This egregious bug seems to be happening more frequently in recent releases. I have noticed it on both osx and linux using builds 15.5.6xx and higher. In some cases the geometry that shouldn't be visible in the viewport even continues to be updated, such as particle simulations that don't have the display flag set any longer.

This is a very frustrating problem to be experiencing.
Edited by jkunz07 - Jan. 22, 2017 17:50:40
User Avatar
Member
166 posts
Joined: March 2013
Offline
I'm hoping it'll be better in H16, but I'm not too optimistic since it's been around for at least a few versions now. Although it's very frustrating I've gotten used to closing my scene view and opening a new one. I would think a button that re-initializes the viewport, without having to do it manually, would be a good solution until/if the bug is fixed.

The most frustrating part is sometimes when you don't realize it's bugged, you pull your hair and have no idea what's going on - and then “..oh right, the bug”. I can just imagine how it is for new people, which Houdini seems to market themselves to more and more. It must be even more confusing for them.
User Avatar
Member
10 posts
Joined: Sept. 2018
Offline
Nearly 10 years later and this is still happening to me. Anyone else having this issue still? I have to keep resetting my UI to only display the things that I want to see.
User Avatar
Member
17 posts
Joined: June 2018
Offline
Same for me ! in 2022
It just make impossible to work...
  • Quick Links