Welding vertices

   831   1   0
User Avatar
Member
1 posts
Joined: July 2006
Offline
Hi,
I've made an HDA to import some geometry into Unity. It has many groups defined in order to load a bunch of “chunks” as separate meshes in Unity.
When I load the HDA into Unity Engine, It fails to create many of the meshes because they have too many vertices. Previously when I imported using OBJs or FBXs the import dialog has a “Weld Vertices” checkbox which defaults to on, so I would wind up with the same number of verts as points. With Houdini Engine there is no access to this dialog or “Weld Vertices” function. As a consequence, my carefully optimized geometry has three times the vertices it needs because there is no longer a way to weld them. It was suggested that in Unity I turn on “Override Split Points by Vertex Attributes” and turn off “Split Points By Vertex Attributes”. I tried this but I still get all those unwanted verts. I also tried turning off “Split Points by Vertex Attributes” in the settings for Houdini Engine in Unity, but still no change.

Is there any way to either weld the verts or to just import the points as the verts for my geometry?

The lack of a weld function or “use points as verts” function reduces the geometry resources of any project by 2/3rds! There must be a way to not have to import three times more verts than you need.

Any help or suggestions would be much appreciated.

Thank you!
User Avatar
Staff
124 posts
Joined: May 2017
Offline
This was a bug with point splitting for vertices over Unity's mesh indices limit. Should be fixed in Houdini 16.0.742. Turn off Split Points by Vertex Attributes and Rebuild asset to import points only, rather than vertices.
  • Quick Links