Stop Houdini from re-baking erosion nodes on file save?

   2220   3   1
User Avatar
Member
75 posts
Joined: Feb. 2017
Offline
I'm working with a height field and several erosions (set on freeze at frame 5), and every time I save the scene, Houdini re-bakes all my erosion nodes in the graph, cause it to take 3-4 minutes to save the scene every time. It's extremely frustrating. I don't remember this being an issue in the past, but I like to save my scene quite often as a force of habit and this is killing my productivity.

I've tried turning the erosion cache off/on and it doesn't matter. I've resorted to selecting a disconnected null node before I save the scene every time, and it saves normally, but this is also quite crazy to have to do. Plus then if i re-select the erosion nodes it re-bakes again anyways… Is there something that got turning on or off somewhere? I checked the preferences and didn't see anything relevant.
Edited by smbell - May 25, 2020 21:41:50
User Avatar
Member
806 posts
Joined: Oct. 2016
Offline
This is a frequent problem for me (Houdini baking when there really isn't anything to bake) and so far my best solution is to use stash-nodes or file-nodes to write out the state at keypoints and manually update them when required.

Marc
---
Out of here. Being called a dick after having supported Houdini users for years is over my paygrade.
I will work for money, but NOT for "you have to provide people with free products" Indie-artists.
Good bye.
https://www.marc-albrecht.de [www.marc-albrecht.de]
User Avatar
Member
75 posts
Joined: Feb. 2017
Offline
malbrecht
This is a frequent problem for me (Houdini baking when there really isn't anything to bake) and so far my best solution is to use stash-nodes or file-nodes to write out the state at keypoints and manually update them when required.

Marc

yeah, I've done that once I get my terrain finalized, but it sure is a hassle when your in the middle of tweaking it. Glad I'm not the only one with issues.

Thanks
User Avatar
Member
75 posts
Joined: Feb. 2017
Offline
Ok, I've put a file cache after the erode and set it to read and it still bakes the erosion node above it when I save the file. This is clearly not right here… I have to disable both my erosion nodes even though they are totally disconnected from the active file node in order for them to not re-bake every time I save.
Edited by smbell - May 29, 2020 21:56:40
  • Quick Links