LINK : fatal error LNK1181: UE4-HoudiniEngineRuntime.lib

   5212   4   1
User Avatar
Member
5 posts
Joined: Sept. 2015
Offline
Hi, I have this error when I tried to package:

UnrealBuildTool: LINK : fatal error LNK1181: cannot open input file ‘C:\Program Files (x86)\Epic Games\4.10\Engine\Plugins\HoudiniEngine\Binaries\Win64\UE4-HoudiniEngineRuntime.lib’

It's possible that it's not in the installer?

Should I build it myself from the source?

Thanks!
User Avatar
Member
173 posts
Joined: April 2014
Offline
Hello. Are you trying to package a game? If so, then at the moment we do not ship UE4 Game modules, only UE4 Editor ones. You would have to build those yourself (UE4 Game target).

Please let me know if this answers your question.
Thanks.
User Avatar
Member
5 posts
Joined: Sept. 2015
Offline
ttvdsfx
Hello. Are you trying to package a game? If so, then at the moment we do not ship UE4 Game modules, only UE4 Editor ones. You would have to build those yourself (UE4 Game target).

Please let me know if this answers your question.
Thanks.

Yes that answer my question, thanks.

Instead of rebuilding UE, I uinstalled the houdini plugins. Then I put the source of HoudiniEngine in my project plugins folder instead. It worked when I tried to package my project
User Avatar
Member
702 posts
Joined:
Offline
I am a total NOOB when it comes to UE…I install UE from the Epic launcher

Do you just remove the HoudiniEngine folder from the UE installed plugins location to remove it ?
How do you go about adding the source of the Houdini Engine to your project plugins folder?



thanks!
User Avatar
Member
453 posts
Joined: Feb. 2013
Offline
Basically you have to turn off the plug-in in the settings. That might crash UE4 (in my experience) and cause unexpected issues, so make a full backup of your project first.

1. Make sure all your HDAs in Unreal are baked out to geo/blueprints/whatever. - It is probably necessary to remove the HDAs from your project (or they might cause crashes).

2. Make a full backup of your project. (Do NOT skip this step.)

3. In UE4 go to settings -> Plugins -> find and deactivate “Houdini Engine” (it's in the Built-in category)

4. Restart and hope for the best. If crashes occur, try restarting Unreal and your project. If you cant get the project running again, start over with another copy of the backup. You can also try overwriting the files of the seemingly broken project with the files from the backup project. Run it and check whether the plug-in is active. - Basically the setting for the plug-in deactivation is the only thing you don't want to overwrite and that setting is in an .ini file, I think.

- It's messed up, but that's based on my experience. It might be different for you.
Edited by DASD - Sept. 26, 2016 03:44:45
  • Quick Links