houdini 16 crashes on start up

   17199   20   7
User Avatar
Member
4 posts
Joined: March 2015
Offline
Are there new system requirement for Houdini 16 15 and older versions work fine Houdini 16 crashes right after splash page with error log only the normal crash window that tells you the file has been saved
User Avatar
Member
459 posts
Joined: Oct. 2011
Offline
I have the same problem on my laptop. Not on my workstation.
Have sent bug report.

-b

Edit: 16.0.535 qt4 seems to be a lot more stable
Edited by bonsak - March 2, 2017 13:12:59
http://www.racecar.no [www.racecar.no]
User Avatar
Member
10 posts
Joined: July 2013
Offline
Same here. Stable on workstation with same Nvidia driver while crashing on laptop. 15.5 is perfect on both systems..
Downloading the 16.0.553 to see if it helps….

EDIT: Same crash with 16.0.553. “12744: Fatal error: Segmentation fault”
Edited by Sahak Sahakian - March 20, 2017 14:07:22
User Avatar
Staff
2500 posts
Joined: Sept. 2007
Online
Hi Sahak! Did you read either of the two threads stickied at the top of this forum? They might help.
Chris McSpurren
Senior Quality Assurance Specialist
SideFX
User Avatar
Member
10 posts
Joined: July 2013
Offline
Thanks for replying Chris. I did try to delete the prefs folder in Documents folder, Clean installing the most recent Nvidia driver, and I just sent a bugg report But I forgot to include info on my Grafics card…
16.0.553
Platform: windows-x86_64-cl19
Operating System: Windows 10 Home x64
Qt Version: 5.6.1
Number of Cores: 8
Physical Memory: 31.92 GB
Number of Screens: 1
Screen 0: 1920 x 1080 at 0,0
Work Area 0: 1920 x 1040 at 0,0
OpenGL Vendor: NVIDIA Corporation
OpenGL Renderer: GeForce GTX 980M/PCIe/SSE2
OpenGL Version: 4.5.0 NVIDIA 378.92
OpenGL Shading Language: 4.50 NVIDIA
Detected: NVidia Consumer
8192 MB
378.92.0.0
Edited by Sahak Sahakian - March 20, 2017 15:16:12
User Avatar
Member
37 posts
Joined: March 2016
Offline
I am having some problems with Houdini 16 crashing as well.

System info:
- Intel Core i7-6700K 4.0 GHz Quad-Core Processor
- MSI GeForce GTX 970 100 Million Milestone Edition Graphics Card
- Windows 10 Pro 64 bit, build 14393.1198

I can barely keep Houdini 16 open for more than a few seconds without a crash. If I am able to keep it open for longer than that, it crashes as soon as I pull up a smooth node.

I did try to uninstall and re-install and that did not help.

Hope this helps solving the problem! Please let me know if there is any more info I can provide to help.
User Avatar
Member
1743 posts
Joined: March 2012
Offline
Ryan Fitzgerald
Please let me know if there is any more info I can provide to help.
What graphics driver version are you running?
Writing code for fun and profit since... 2005? Wow, I'm getting old.
https://www.youtube.com/channel/UC_HFmdvpe9U2G3OMNViKMEQ [www.youtube.com]
User Avatar
Member
37 posts
Joined: March 2016
Offline
Driver Version is 382.05
User Avatar
Member
350 posts
Joined: June 2016
Offline
Same here
Houdini 16.0.633
Ubuntu 16.04 LTS xenial
Nvidia driver 381.22
User Avatar
Member
63 posts
Joined: Aug. 2013
Offline
Hello, I too have recently run into problems with Houdini 16 crashing. I've been running Manjaro 17 with the XFCE desktop, but the problem doesn't seem to be with the OS or the NVidia drivers. After days of web browsing without finding an answer, I decided to risk ruining the Houdini install rather than the OS, based on the vague assumptions I gleamed from my internet usage. At first I tried things like editing the bash environment and houdini_setup scripts to make Houdini load Manjaro's Build of the Qt5 libraries, and then I tried installing a local version of Qt5, but Houdini loaded its own version anyway. Then I tried deleting all the Qt5 libraries and any other library that Manjaro already had installed, including libz, libssl, and libcrypto, and then launched Houdini, which didn't work. So I returned the Qt5 libraries, and—Houdini fully started up! At long last it seemed that everything was working, until I opened a help browser tab, and then it Houdini froze and a bunch of errors showed up about something or another about QtSSlSomething…missing symbol…blah blah blah…So it appears the real problem is with the OpenSSL library that comes with the Houdini instillation. The final step that seems to have fixed everything is by copying Manjaro's ibssl.so.1.0.0, libcrypto.so.1.0.0, and libz.so.1 from /usr/lib, to Houdini's dsolib directory, overwriting Houdini's versions of those same .so files. Now everything appears to be back to normal, except that now X11 is broken from my switching to the unsupported nvidia beta drivers (381.22), which wouldn't be a problem if I never wanted to logout/lock my screen and instead favored full shutdowns/restarts instead. But I also hope this story might help other Linux artists who want their Houdini 16 to work again…
User Avatar
Member
279 posts
Joined: Dec. 2009
Offline
HongMao
So it appears the real problem is with the OpenSSL library that comes with the Houdini instillation. The final step that seems to have fixed everything is by copying Manjaro's libssl.so.1.0.0, libcrypto.so.1.0.0, and libz.so.1 from /usr/lib, to Houdini's dsolib directory, overwriting Houdini's versions of those same .so files. But I also hope this story might help other Linux artists who want their Houdini 16 to work again…
Thanks for this trick, it's working but starting houdini take a lot of time, more than one minute !
For info, i replaced libz.so.1.0.7 by the libz.so.1.0.11 from /usr/lib/ and relinked the other libz.XX
I'm under Manjaro (i3wm) with the last nvidia driver from manjaro, 375.66
User Avatar
Member
37 posts
Joined: March 2016
Offline
Has anyone solved this for Windows yet? I am on Windows 10, and I purchased a Houdini Indie license. The teacher in the course I am taking has Houdini 16, but I can only use 15.5 as of right now.
User Avatar
Staff
1259 posts
Joined: July 2005
Offline
Ryan Fitzgerald
Has anyone solved this for Windows yet? I am on Windows 10, and I purchased a Houdini Indie license. The teacher in the course I am taking has Houdini 16, but I can only use 15.5 as of right now.

Do you have a crash log or stack trace?

Also, try running the Qt4 build instead of the main one and see if that helps.

Cheers,
Rob
User Avatar
Member
63 posts
Joined: Aug. 2013
Offline
fsimerey
HongMao
So it appears the real problem is with the OpenSSL library that comes with the Houdini instillation. The final step that seems to have fixed everything is by copying Manjaro's libssl.so.1.0.0, libcrypto.so.1.0.0, and libz.so.1 from /usr/lib, to Houdini's dsolib directory, overwriting Houdini's versions of those same .so files. But I also hope this story might help other Linux artists who want their Houdini 16 to work again…
Thanks for this trick, it's working but starting houdini take a lot of time, more than one minute !
For info, i replaced libz.so.1.0.7 by the libz.so.1.0.11 from /usr/lib/ and relinked the other libz.XX
I'm under Manjaro (i3wm) with the last nvidia driver from manjaro, 375.66

Yeah, the graphics driver version seems to be unresolvable with Manjaro. I hate having to switch distros just to get a single program working, but I guess that's part of the fragmentation issue that Dedoimedo warns may compeletly end Linux as a product, though I feel that Linus perpetually giving Nivida the cold shoulder will kill it faster…
User Avatar
Member
37 posts
Joined: March 2016
Offline
Thanks Rob! Qt4 actually opens and is working fine so far. With Qt5 I could barely keep it open for a few seconds before I got the “Fatal Error: Segmentation Fault” message. I did uninstall Qt5 before installing QT4. Is there still a way for me to access the old crash log?

Are there any disadvantages to having to use QT4?
User Avatar
Staff
1259 posts
Joined: July 2005
Offline
Hi Ryan,

Crash logs are saved in your Houdini temp directory which on Windows I believe is located at C:/Users/myUser/AppData/Local/Temp/houdini_temp(hopefully someone on Windows can correct me if I'm wrong). Crash log files are named crash.*.txt.

And there are no disadvantages to using the Qt4 build. Qt4 vs Qt5 only really matters if you are developing plugins that use Qt or PySide or PyQt. Eventually we will drop the Qt4 build altogether in a future Houdini major release but that's at least one year from now and won't affect H16.0 builds.

Cheers,
Rob
User Avatar
Member
168 posts
Joined:
Offline
Having problems as well with fresh Fedora 26. Centos 7 was fine-ish (had to change NVIDIA driver version)
So far I have tested:
Houdini: 16.0.633, 16.0.671, 16.0.671 QT4, 16.0.680, 16.0.682, 16.0.683
Nvidia: 375.66, 384.47, 381.22, 375.82, 384.59
Results more or less the same (crashes on start)

Solution: add ‘HOUDINI_USE_HFS_PYTHON=1’ to houdini.env file

Example:

Houdini 16.0.683
System Fedora26 (4.11.11-300.fc26.x86_64)
Nvidia: 375.66
> houdini
Could not initialize the help server:
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "/opt/hfs16.0.683/houdini/python2.7libs/houdinihelp/__init__.py", line 1, in <module>
from houdinihelp.api import *
File "/opt/hfs16.0.683/houdini/python2.7libs/houdinihelp/api.py", line 8, in <module>
from bookish import paths, textify, util, functions, stores
File "/opt/hfs16.0.683/houdini/python2.7libs/bookish/textify.py", line 31, in <module>
from bookish import compat, util
File "/opt/hfs16.0.683/houdini/python2.7libs/bookish/util.py", line 35, in <module>
import shutil
SystemError: NULL result without error in PyObject_Call

5403: Fatal error: Segmentation fault (sent by pid 40)
Crash log saved to /tmp/houdini_temp/crash.ats_5403_log.txt
> cat /tmp/houdini_temp/crash.ats_5403_log.txt
Crash report from ats; Unknown App Version 16.0.683 [linux-x86_64-gcc4.8]
Uptime 0 seconds
Tue Aug 1 04:38:44 2017
Caught signal 11

Traceback from 5403 ThreadId=0x7f1833de2d00
AP_Interface::coreDumpChaser(UTsignalHandlerArg) <libHoudiniUI.so>
AP_Interface::si_CrashHandler::chaser(UTsignalHandlerArg) <libHoudiniUI.so>
signalCallback(UTsignalHandlerArg) <libHoudiniUT.so>
UT_Signal::UT_ComboSignalHandler:perator()(int, siginfo*, void*) const <libHoudiniUT.so>
UT_Signal::processSignal(int, siginfo*, void*) <libHoudiniUT.so>
__funlockfile <libpthread.so.0>
je_arena_dalloc_bin_locked (arena.c:1897)
je_tcache_bin_flush_small (tcache.c:127)
je_tcache_event_hard (tcache.c:39)
malloc (tcache.h:271)
UT_StringRef::Holder::build(char const*, UT_StringRef:torageMode) <libHoudiniUT.so>
UT_UIOptionParser::parseLine(char const*, UT_SymbolMap<UT_StringHolder>&) <libHoudiniUT.so>
UT_UIOptionParser::load(char const*, UT_IStream&, UT_SymbolMap<UT_StringHolder>&) <libHoudiniUT.so>
UT_OptionFile::load(char const*, UT_IStream&) <libHoudiniUT.so>
UT_OptionFile::load(char const*) <libHoudiniUT.so>
UI_IconBase::fetch(char const*, bool, UI_IconScalability, bool, bool) <libHoudiniUI.so>
UI_Icon::UI_Icon(char const*, UI_BorderType) <libHoudiniUI.so>
UI_IconButtonLook::UI_IconButtonLook(char const*, bool) <libHoudiniUI.so>
SI_HelpButton::setDefaultLook() <libHoudiniUI.so>
si_parse(SI_Parse*) <libHoudiniUI.so>
SI_Parse::parse(_IO_FILE*, char const*, bool) <libHoudiniUI.so>
AP_Interface::readUIFile(char const*, bool) <libHoudiniUI.so>
FUSE_ColorOptions::initApplication(UI_Manager*, int, char const**) <libHoudiniAPPS3.so>
FUSE_ColorOptions::FUSE_ColorOptions() <libHoudiniAPPS3.so>
FUSE_ColorOptions::dialog() <libHoudiniAPPS3.so>
FUSE_App::FUSE_App(char const*) <libHoudiniAPPS3.so>
FUSE_HoudiniBinariesApp::createApplication(int&, char const**) <libHoudiniAPPS3.so>
OPUI_MainApp::initApplication(UI_Manager*, int, char const**) <libHoudiniAPPS2.so>
main <libHoudiniUI.so>
__libc_start_main <libc.so.6>
_start <houdini-bin>
Edited by tmdag - Aug. 1, 2017 15:07:44
Albert
User Avatar
Member
168 posts
Joined:
Offline
updated my previous post.

Sidefx helped with solution:

add ‘HOUDINI_USE_HFS_PYTHON=1’ to houdini.env file and that fixed my problems.
Albert
User Avatar
Member
1 posts
Joined: Nov. 2017
Offline
Hi guys this is going to be my first Post. Houdini was constantly crashing on my laptop due to segmentation errors and i had no clue why.


1. I tried to add a permission for houdini to pass the Windows firewall (added mplay and hmaster too)

Widows firewall –> add permission….

2. Then i Right - clicked on houdini fx and chose “open with graphics card –> NVIDIA GEforce….”




I dont know why this worked for me but everything works fine right now. It seems like my video card kinda failed to initialize on the startup of Houdini…. hope this helps

Greetings from Germany
Edited by Tamosch94 - Nov. 13, 2017 20:20:41
User Avatar
Member
12 posts
Joined: Dec. 2016
Offline
I'm using Apprentice v16.5.496 (GPU drivers: v388.59 & v391.35) and it still crashes within minutes when the work begins. If I leave it alone after launching, it doesn't crash. The moment I add a color node though, the program simply disappears.

Reinstallation didn't fix it. This included cleaning out my hard drive of any remnant v15 stuff.

Firewall permissions are already allowed for everything Houdini.

From tmdag
Sidefx helped with solution:
add ‘HOUDINI_USE_HFS_PYTHON=1’ to houdini.env file and that fixed my problems.

Where is this file? SOLVED= *> Documents > houdini16.5 …

Where is the crash log or stack trace? SOLVED= From the help desk…
  • Help -> About Houdini -> click on “Show Details” -> Save
  • or…
  • …users > YOU > AppData > Local > Temp > houdini_temp > crash.untitled.YOU.hipnc

Thanks in advance.
Edited by ChazS - July 9, 2018 18:07:53
  • Quick Links