"no Houdini Digital Asset selected" when another team member opens my max project

   157   2   1
User Avatar
Member
8 posts
Joined: Oct. 2017
Offline
Hello

I have created an HDA for use in 3dsmax as a modifier, and on my pc, everything is working fine, when I reopen my max project, as soon as I start a session from the Houdini engine window in 3dsmax, all the assets in the scene update and generate the proper geometry.

Now, on another team member's pc, we have setup Houdini indie with the proper license, tested a sample asset in 3dsmax, and tested applying my asset to a new object as a modifier, and everything works properly.

However, the objects I had already set up in the scene, do not appear to be “seen” by the engine. When we go to the modifier stack, there is just the “Houdini Digital Asset” placeholder modifier, but on the Houdini Engine window's parameters tab, we just see “no Digital Asset selected”.
We have even tried “open scene in Houdini” from the debug tab, and the only object that showed up was the new one we created to make sure the asset was working, confirming that the engine does not “see” the others.

I think maybe the problem is that the hda was on a different folder on my pc, but without the modifier/asset being recognized, I cannot get the “show Advanced options” at the bottom of the parameters window, to change the HDA path.
I have also tried adding the new folder to the “HDA search path”, “HDA load directory”, and even “otl search path” prior to starting the session, but still nothing.

Please help us solve this, thanks in advance
Emanuel “Manoo” Raimundo
3D generalist, going procedural!
www.artstation.com/manoo
User Avatar
Staff
175 posts
Joined: Aug. 2017
Offline
Hi Emanuel,

Are you able to PM me the .hip file so that I can debug the issue? Adding the folder to the HDA search path and/or HDA load directory should allow your team member to open the file have the assets load correctly.

Another thing that you can try is to copy the .hda file into the same directory as the .max file, as the plugin will also search in the .max file's location if the HDA cannot be found.
User Avatar
Member
8 posts
Joined: Oct. 2017
Offline
Hello Brandon,

Unfortunately, my client does not allow me to send the asset.

However, I did try on my laptop pc, with the .hdalc in the same folder, then I added its path to the HDA search path and HDA load directory, and nothing worked.

In the end, I worked around the problem by going back my desktop PC, creating a C:\HDA folder (easier to create on other pc's), and in the asset's parameters “advanced options”, changing its path to “C:\HDA”
Emanuel “Manoo” Raimundo
3D generalist, going procedural!
www.artstation.com/manoo
  • Quick Links