Very Large Scene Perspective Camera

   5075   6   1
User Avatar
Member
245 posts
Joined: 9月 2011
Offline
I quite sure I cant be the only one with this problem:

When working in a large scale scene, for example I created a very large railroad track. Sometimes I want to zoom in on certain parts, but since the scene is really HUGE the camera slows down zooming in to its maximum zoom functionality. Which make it very very hard to navigate..

Im not sure if you guys know what im talking about, its actually quite hard to explain this.

I could make a video if you guys dont have a clue what im talking about.

But this usually happens when you zoom in on parts far beyond the object's origin.. this also happens in maya.. it is very very very annoying and I was wondering if anyone knows a solution for this?

Cheers!
User Avatar
Member
250 posts
Joined: 2月 2013
Offline
Why don't you space+g on the object you want to focus on ? Doing this you will adapt the scale of your view. Or I don't understand your question…
https://vimeo.com/obreadytom [vimeo.com]
User Avatar
Member
245 posts
Joined: 9月 2011
Offline
Its not the same, try doing that on a very large object..
I've attached an obj I made a while ago.

Please load the model into a new scene and try zooming in on a small section of this model, try looking at any of the planks:

-You will see camera clipping (I dont know how to fix this)
- It will be very hard to navigate when zoomed in (zoom, pan, dolly)
- Space G will just center the entire object

Attachments:
railTracks.rar (2.9 MB)

User Avatar
Member
572 posts
Joined: 11月 2005
Offline
try selecting the plank You want to inspect and press shift-g.

or use a camera to view your object than You can adjust the clipping planes
User Avatar
Member
245 posts
Joined: 9月 2011
Offline
Hmmm why havent I tried this before.. just using primitive selection..

I feel kinda stupid now.. I've had this problem for a long time.. also in Maya.. thanks!
User Avatar
Member
8330 posts
Joined: 7月 2007
Online
johnnycore
Its not the same, try doing that on a very large object..

-You will see camera clipping (I dont know how to fix this)
…t

in any viewport press to go to Display Options, then Viewport/Clipping to set clipping planes on the view (if it's camera then the settings are on camera object)
Tomas Slancik
FX Supervisor
Method Studios, NY
User Avatar
Member
245 posts
Joined: 9月 2011
Offline
Ah yes.. of all places I have not looked in the viewport options itself!
I was looking in the preferences..
Thanks!
  • Quick Links