Houdini slowness using Gentoo [solved]

   8399   7   2
User Avatar
Member
10 posts
Joined: Sept. 2008
Offline
I have been trying to decide whether to post this on the Gentoo or the Houdini forums…and I'm still not sure but here goes!

This was tested with Houdini Apprentice 9.5.170 and 9.5.230 on a 64bit linux operating system (houdini-9.5.170/230 linux 64 bit gcc 4.2 build) in KDE 3.5 running on Intel(R) Core(TM)2 Quad CPU Q9450 @ 2.66GHz with 2GB RAM.

I have recently updated my Gentoo system and everything on my system seems to be working great (Blender, Gimp, Picasa, image viewers, Firefox, Flash etc) except for Houdini.

Problem: Upon opening houdini, I am greeted with the splash screen which dissapears (which is normal) but then I am greeted with this screen after a few more seconds of waiting (attached as snapshot17.png). It looks different depending on what was last in the video frame buffer and the video driver is not the cause of the problem. I rolled it back, tried houdini, updated the driver, tried houdini but to no avail.

Any interaction with the UI takes very long to do anything. Houdini is usually unresponsive for anything from 5-10 seconds when simply highlighting a shelf icon or anything similar. It also takes long to load the panels on the right-hand side of the window when switching between tools (e.g. Camera / select mode). Refer to snapshot18.png.

It is important to note that Houdini starts up maximized. My window manager itself doesn't suffer this lack-of-responsiveness problem. I can easily click on the minimize/maximize buttons whilst Houdini lagging.

When I click the maximize button (whilst Houdini is maximized) to put houdini in non-maximized mode Houdini then works perfect. Going back into maximized mode Houdini is still working good. It's just that first initialization that is causing problems for me.

Has anybody encountered this problem? It's not a total showstopper bug, it's just a mild annoyance to have houdini start up with all that slowness.

Kind Regards,
Van Aarde.
Edited by - Oct. 3, 2008 14:56:47

Attachments:
snapshot18.png (215.7 KB)
snapshot17.png (153.1 KB)

User Avatar
Staff
3455 posts
Joined: July 2005
Offline
what graphics card are you using?
Michael Goldfarb | www.odforce.net
Training Lead
SideFX
www.sidefx.com
User Avatar
Member
519 posts
Joined:
Offline
I have used gentoo too and houdini ran just fine. So guess it's either your hardware or a wrongly configured xorg.conf file.
User Avatar
Member
10 posts
Joined: Sept. 2008
Offline
@arctor: I have an NVidia 8800GT using nvidia drivers version 177.70

@Pagefan: Did you use Houdini on a very recently updated gentoo system?

Like I said, this only happenend when I updated my gentoo about 3 weeks ago. Before that, everything was fine and dandy.

All I can think is that some library or driver implementation changed a bit which is breaking Houdini.
User Avatar
Member
460 posts
Joined: July 2005
Offline
do you have the composite extension enabled?

if so, disable it, houdini doesn't like it,
varomix - Founder | Educator @ Mix Training
Technical Artist @ Meta Reality Labs
User Avatar
Member
519 posts
Joined:
Offline
Add these to xorg.conf….

Section “ServerFlags”
Option “AIGLX” “off”
EndSection

Section “Extensions”
Option “Composite” “Disable”
EndSection
User Avatar
Member
10 posts
Joined: Sept. 2008
Offline
Thank you doctor varomix. Your prognosis was spot on!

I thought that commenting out the following line would actually disable Composite:
Option “Composite” “Enable”

But it seems that I had to explicitly disable it:
Option “Composite” “Disable”

Thanks everyone! Now I can get back to making VFX!

–edit–
Thanks for your help as well Pagefan! You replied whilst I was typing this post so I saw your post a bit late!
Edited by - Oct. 4, 2008 08:17:43
User Avatar
Member
460 posts
Joined: July 2005
Offline
glad to know you fixed that

In the latest versions the composite extension in enabled even if not declared in the .conf file, so you have to explicitly declare it to off.
varomix - Founder | Educator @ Mix Training
Technical Artist @ Meta Reality Labs
  • Quick Links