Flip Fluids Stop Filling

   5526   4   3
User Avatar
Member
7 posts
Joined: June 2016
Offline
Can anyone explain to me why my simulation seems to cut off here even though I have plenty of frames? It just slows down at this point and won't fill up any more. There are no leaks, the death rate isn't the issue that I can tell. I used the same setting that I used in a similar simulation and it's still not working for some reason. Any idea what settings I should check?

Attachments:
fluidissue.png (2.7 MB)

User Avatar
Member
5 posts
Joined: July 2011
Offline
Is your fluid emitter below the surface of the fluid level?

If so this will stop the fluid from filling up once it gets to a certain level. You can use the divergence attribute to ‘inflate’ the fluid and raise the level that way. It takes quite a while to fine tune the right value. From what I remember you need to turn off reseeding when using divergence or the effect can be cancelled out.


User Avatar
Member
7 posts
Joined: June 2016
Offline
Yes, my fluid emitting is at the bottom of the tub. How should I adjust the divergence attribute? I'm not familiar with it. My reseeding is already turned off.
Edited by pmurra20 - Aug. 25, 2016 07:41:07
User Avatar
Staff
2536 posts
Joined: July 2005
Offline
Use the Populate Containers Shelf “Expand from…” shelf tool to add a divergence expansion field to your fluid simulation DOP object.

It is common to take your emitter poly surface geometry, object merge in to a new object and run the Expand from… shelf tool to add a divergence field to your FLIP sim.

You also have to enable the “Add Divergence Field” toggle on the FLIP Object DOP.

Control the rate of fill by key framing the divergence source amount.

see the attached scene file.

Attachments:
fill_tube_from_bottom_H15.5.hip.zip (1.0 MB)

There's at least one school like the old school!
User Avatar
Member
7 posts
Joined: July 2013
Offline
Hi,
I tried your example and it worked like a charm with a narrow glass. But if I widen up the radius of the collision glass, then it doesn't work the same..
Even If I enlarge the emitor, the divergence isn't enough.

And a bigger problem is :
With your narrow version, when you animate the divergence sourcing to 0, the water level stays and doesn't go down. In my wider version, the water level drops as if no divergence was added to the sim..

How can I make the water level rise even in wider pools and more importanly, how can I keep the water level exactly where I want it?

Thank you!

Attachments:
fill_tube_from_bottom_H15.5_bigger.hiplc (1.8 MB)

  • Quick Links