Houdini uses 100% of CPU when cooking..

   2567   7   1
User Avatar
Member
14 posts
Joined: Jan. 2017
Offline
Houdini FX 15.5.523
OSX EL Capitan 10.11.4
CPU: 2 x 2.93 GHz 6-Core Intel Xeon
RAM: 16 GB 1333 MHz DDR3 ECC
GPU: ATI Radeon HD 5870 1024 MB

When running cooking operations, Houdini uses 100% of my CPU, essentially freezing my computer. ESC. doesn't cancel it and i end up having to force quit the application. I'm really getting tired of not being able to cook anything. Only setting i could find for it was under Edit > Preferences > Compositing > Cooking. Tried disabling multithread cooking which was only set to 24 threads in the first place, tried enabling GPU assistance and and neither of these seem to make much of a difference. In activity monitor it gives me something like 800% CPU usage for Houdini but then says 50% of my CPU is still idle..

Anyone else had this issue or know of a possible fix?
User Avatar
Member
4129 posts
Joined: June 2012
Offline
You can set the number of thread by the -j flag. From the Houdini terminal:

houdini -j20

would be 20 threads - including hyperthreading, that would leave 4 for the computer.

Edited for the dual procs
Edited by goat - Jan. 6, 2017 04:25:05
User Avatar
Member
14 posts
Joined: Jan. 2017
Offline
Artye
You can set the number of thread by the -j flag. From the Houdini terminal:

houdini -j20

would be 20 threads - including hyperthreading, that would leave 4 for the computer.

Edited for the dual procs

Very useful! thank you! any way to allocate a certain amount of RAM to Houdini as well? I found that it also uses all of my RAM.
User Avatar
Member
14 posts
Joined: Jan. 2017
Offline
Still having trouble with this. In Activity Monitor (Mac OSX Task Manger equivalent), even after using Houdini -j20 to launch, it still uses up to “1500%” of my CPU.. which makes absolutely no sense to me.. Under Memory it also states Houdini is using as much as 55 GB of my 16 GB of available RAM..

How can a program use 1500% of my CPU and almost 4 times my available amount of RAM??

Every time i do anything even remotely intensive (cooking, simulating, etc.) These numbers essentially rise infinitely until Mac OSX pauses the program, stating that i have no memory left to run it. At this point i have no option but to force quit Houdini.

All i need is a reliable way to truly limit the CPU and Memory usage of Houdini..

If someone could offer me any suggestions at all, I'll try just about anything at this point. This is beyond frustrating.
Edited by notalk - Jan. 10, 2017 04:09:55
User Avatar
Member
4129 posts
Joined: June 2012
Offline
55GB isn't the upper bound, the OS can access up to 18 exabytes. 24 cores x 100% means it should be able to go to 2400%; 1500% is just above half.

In the end you need more ram. Unix doesn't really allow you readily limit memory usage, though you can always try ‘ulimit’:

http://unix.stackexchange.com/questions/108174/how-to-persist-ulimit-settings-in-osx-mavericks [unix.stackexchange.com]
User Avatar
Member
14 posts
Joined: Jan. 2017
Offline
Artye
55GB isn't the upper bound, the OS can access up to 18 exabytes. 24 cores x 100% means it should be able to go to 2400%; 1500% is just above half.

In the end you need more ram. Unix doesn't really allow you readily limit memory usage, though you can always try ‘ulimit’:

http://unix.stackexchange.com/questions/108174/how-to-persist-ulimit-settings-in-osx-mavericks [unix.stackexchange.com]

Okay, i figured something out.. all the models i was using in the sims were .FBX.. i converted them all to .OBJ and the sims run flawlessly. Really weird, not sure why. Went ahead and bought 16 more GB's of RAM anyways.

Thanks for your continued help, Artye.
Edited by notalk - Jan. 15, 2017 13:10:28
User Avatar
Member
1 posts
Joined: June 2019
Offline
Hello, I am a new Houdini 17.5 user and having the same problem. Specifically with solvers Houdini starts calculating a few frames, then freezes up and no way to continue other than to shut down the program.

My system runs an 18 core Intel I9 9980XE dual 3Ghz processor, 64GB of RAM, NVidia GeForce RTX2080ti graphics card, ASUS X299 Prime motherboard, 2x2 Terabytes of SSD on board hard drive, Windows 10 Pro, 64 bit.

When Houdini freezes task manager shows I'm at about 7% CPU usage and 10% Memory usage. Yet this program is completely unresponsive and stays that way indefinitely. In the meantime I can still play YouTube videos and run other programs, no problems, so the computer itself doesn't seem to be resource challenged at all, just Houdini. What's up with that?

Is there some setting I need to set or something I can do to ensure Houdini gets to use more of the computer's resources?
User Avatar
Member
46 posts
Joined: April 2018
Offline
Not sure if this is helpful, but I've run into the same issue. But with with specific simulations. Such as water, particle advection,pretty such anything involving the particlestoVDB node, and sometimes lava. What it really comes down to is to understand what things your computer can and cannot handle. So you can plan ahead and add caches or keep your voxels at a suitable level. Using the flipbook usually helps so much with the cooking issues I'm finding.
Procedural Girl
  • Quick Links