Mantra Render View gives out different results when saved as TARGA file.

   568   4   1
User Avatar
Member
6 posts
Joined: April 2017
Offline
Hello,
So I've been having issues with my renders not outputting the same visual images as what I see in Renderview.
I turn off Gamma, and also set my renders to 8 bit integer to keep out the GAMMA from rendering. I tried out different option as well but I get this really bright and heavily blown out contrast image as the result as well.
Not really sure where to go from here. Help would be greatly appreciated.
Thanks!
-Daniel

Attachments:
Capture.JPG (172.7 KB)

User Avatar
Member
2101 posts
Joined: Sept. 2011
Offline
looks like a difference of opinion on whether the image should be unpremultiplied. Don't use weird formats that some software expects a certain way. Avoid targa, png, tif, etc. Stick to exr and jpg, they are the only known quantities when it comes to image formats. Avoid photoshop if possible.
User Avatar
Member
6 posts
Joined: April 2017
Offline
jsmack
looks like a difference of opinion on whether the image should be unpremultiplied. Don't use weird formats that some software expects a certain way. Avoid targa, png, tif, etc. Stick to exr and jpg, they are the only known quantities when it comes to image formats. Avoid photoshop if possible.

Thanks for the suggestion jsmack. I've tried to use EXR as a image format using “Save to Disk”. The image size of the EXR renders out a LOT smaller and it also cuts out all the alpha which moves the image around when viewed in After Effects. I kind of have to use Photoshop/After Effects to edit my images as well. As for JPG, it won't work since I need alpha out of these images. These turn into sprite sheets which gets used in a game engine. I'll keep trying different method though. If there's any more suggestions, please let me know.
Thanks all!
-Daniel
Edited by wooyangkim - May 2, 2018 13:09:46
User Avatar
Member
172 posts
Joined: March 2015
Offline
Hi, I don't use After Effects so I'm not sure about the “moves the image around” part. (I assume After Effects is cropping it using the transparency) If you open an exr in Photoshop, you should get the option to keep alpha as a channel or apply it as a transparency. (see attached)

Attachments:
Exr_Alpha_option.jpg (23.7 KB)

User Avatar
Member
6 posts
Joined: April 2017
Offline
So here are the different formats I've tried. It seems that JPEG gave me the best result. It doesn't really give me a proper alpha to change the background color but I guess this will do for now.
I think it's a color clamping issue with all these different formats and they're all giving different results. I really wish there was an easy option to clamp the colors better with any format so it's close to what the user sees on screen. All this underlying format issues are really confusing to me.

Attachments:
Capture3.JPG (124.1 KB)
Capture2.JPG (140.0 KB)

  • Quick Links