Exploding hair with "Guidepartition"

   1897   3   2
User Avatar
Member
425 posts
Joined: March 2014
Offline
I'm trying to use the “guidepartition” node to divide 2 sides of a hair groom.

It initially looked fine, but when I play the simulation I get these “exploding hairs” going from the “guide partition”curve to the world origin.

I also added a “rest” node.

I only see it at rendertime, so it might be a Redshift issue.

Has anyone else noticed this ?

Houdini 18.0.460 / RS 3.0.21

R.
Edited by toonafish - June 1, 2020 11:46:46

Attachments:
hair_parting_explode_02.jpg (46.4 KB)

User Avatar
Member
806 posts
Joined: Oct. 2016
Offline
I have had this problem a lot when using Redshift. Most of the times I managed to get around it by breaking the simulation/deformation, often it was some mismatch of groom/guide/rest geometry that wouldn't cause any harm with Mantra but went bonkers with Redshift. At times I *thought* it might be a scaling thing, as it didn't happen when NOT using any scale in the scene (or not using any object-merge, which I use *a* *lot*).

Unfortunately, I cannot provide a robust solution, but I can confirm that it *feels* like a Redshift thing.

Marc
---
Out of here. Being called a dick after having supported Houdini users for years is over my paygrade.
I will work for money, but NOT for "you have to provide people with free products" Indie-artists.
Good bye.
https://www.marc-albrecht.de [www.marc-albrecht.de]
User Avatar
Member
425 posts
Joined: March 2014
Offline
Hey thanks, I’ll post it in the Redshift forum as well.

Could be a scaling issue as you mention, there are some scaled objects involved. I’ll see if baking the scaling eliminates the issue.
User Avatar
Member
953 posts
Joined: April 2008
Offline
I am having the same issue, does anyone has a solution?
https://vimeo.com/user2163076 [vimeo.com]
  • Quick Links