Rigged Character- Rigging Bug when moving in World Space

   1793   4   1
User Avatar
Member
117 posts
Joined: Nov. 2011
Offline
Hello, I have a character which is rigged and is working, but when I move the Primary Null up more than 10 units in Y space, the rig has an error on the arms and they collapse down. I have tried recaching and cannot determine what is causing the problem.

This is very frustrating to have spent quite a long time adjusting the weight painting on this character to have this problem. If you could point out what is causing this please let me know. I tried putting the character into a subnet but the problem occurs there as well.

I have included a link to he scene and mesh below.

https://www.dropbox.com/sh/2ozbb31v4isv9mk/AACit8mJ7bdMP1HRqv_unLvsa?dl=0 [www.dropbox.com]
Edited by BradASchreiber - June 16, 2020 18:33:12
Brad Schreiber
User Avatar
Member
806 posts
Joined: Oct. 2016
Offline
Hi,

maybe I am missing what you mean by “moving the primary null” (I used the “master_ctrl”), to me, moving the rig up is looking fine:





Marc

Attachments:
01.jpg (147.8 KB)
02.jpg (126.8 KB)
03.jpg (121.5 KB)

---
Out of here. Being called a dick after having supported Houdini users for years is over my paygrade.
I will work for money, but NOT for "you have to provide people with free products" Indie-artists.
Good bye.
https://www.marc-albrecht.de [www.marc-albrecht.de]
User Avatar
Member
117 posts
Joined: Nov. 2011
Offline
Thank you malbrecht, yes I meant the master ctl node. I am still getting pinching deformation at the elbows when I reposition in Y-space (positive or neagtive) using the master ctl node. I'm not sure how the bug is not recreating on your end, I will try merging into a fresh project and see if that corrects the error.
Brad Schreiber
User Avatar
Member
806 posts
Joined: Oct. 2016
Offline
Ah, I see what you mean - when you wrote that “the arms collapse”, I really only looked at “the arms”, not at the elbows

The problem seems to be somewhere in the “arms noodle” setup, I assume there is a rotation or maybe a scale messed up. As soon as I have a free system available, I'll try to figure it out …

Marc
---
Out of here. Being called a dick after having supported Houdini users for years is over my paygrade.
I will work for money, but NOT for "you have to provide people with free products" Indie-artists.
Good bye.
https://www.marc-albrecht.de [www.marc-albrecht.de]
User Avatar
Staff
3456 posts
Joined: July 2005
Offline
I exported the AutorigsSettings from your Rig and built a new rig, but I can't reproduce the errors you're reporting…

if you're able to track down what has caused this please let us know with a bug report.

thanks
Michael Goldfarb | www.odforce.net
Training Lead
SideFX
www.sidefx.com
  • Quick Links