Houdini 18 VAT to Unreal Engine 4.25

   869   2   0
User Avatar
Member
2 posts
Joined: April 2019
Offline
Hi Everyone!

I am new to Houdini and I want to use VAT for a project FX I am doing. I have followed the tutorial from Andreas Glad for the Paintsplat in Unreal and it worked fine for everything except the resizing and the mesh rotation in the particle system. But that is (probably) not the reason why I am here.
I am having issues with importing my vertex animation texture in Unreal from an export made in Houdini via the VAT node in the SideFX Labs tab. I am currently trying to make the animation of a blooming flower. I set it as a soft body and export the files needed. But the problem is when I import everything in Unreal, I get flipping and shifting polygons through eachother. I have been looking on internet since yesterday to see if anybody have had the same issue but I haven't found anything and I feel a bit helpless at the moment.

Here is what it looks like : https://drive.google.com/file/d/1PsGZDWjB91cBvkCkfShqpqRn-Ps2ncod/view?usp=sharing [drive.google.com]

I have copy and pasted the material shader code in a material function. Here is how I have plugged everything in the material:https://drive.google.com/file/d/11eOZE_9XZE1vrybQXBeexFGXqY-KLZOy/view?usp=sharing [drive.google.com]

Here is what it's supposed to look like: https://drive.google.com/file/d/14dtJck4S4kZYqGlWO2B_tWDqZvB-Q2WG/view?usp=sharing [drive.google.com]

I don't know if the problem comes from something I didn't plug right, if it comes from the code or the mesh generated by houdini,or something else.

If someone has any idea on why I get this kind of result and wants to help, it would be SO much appreciated!

Thank you!
Edited by GoldenNebula - July 27, 2020 15:14:17
User Avatar
Member
1 posts
Joined: July 2018
Offline
Hey Nebula,

the animation looks great! Maybe that issue is solved for you by now, but for others: the trick is to check “Use Full Precisions UV's” in the VAT (Vertex Animation Texture).

That's it
User Avatar
Member
1 posts
Joined: March 2017
Offline
Hey guys, not sure if I need to make a new thread for this, Ill first try here like this:

Im currently learning Unreal Engine, specifically interchange between houdini & unreal.

I was able to use the labs tools rbdtofbx and vats to succesfully transfer destrucution sim of an animated plane and a meshed pyro sim to unreal. what I need to do now is parent the pyro to the plane in unreal, but as soon as i do this the vats mesh simply disappears.

I can parent other geometric objects to the plane without problems, also default particle systems. No issues there. Also no scaling on the objects that could cause any problems.
I can also parent the Vats object to an empty actor, or to a camera.
But it disappears when I parent it to anything that was imported from houdini (also have a shotcam that i tried it with, same result)

Any pointers would be greatly appreciated as Im still struggling with how to troubleshoot these things in unreal.

Cheers
Jan
  • Quick Links