How to fix tree scatter bug in Houdini Engine 6.2.0

   763   2   0
User Avatar
Member
5 posts
Joined: May 2021
Offline
So the trees are not scattering anymore when I upgrade Houdini Engine to version 6.2.0
This is because Houdini Engine seem to now assume there are two parts to every tile.
In the insanely long function "GenerateTerrainBuffers()" on line 914:

HEU_TerrainUtility.GetAttributeTile(session, nodeID, scatterInstancerParts.id, out terrainTile);

when the terrain is loaded ales where this function returns the tile number (if the tile has an attribute called "tile" set in the heightfield). But here in GenerateTerrainBuffers it assumes that there is a Part 2 to every tile which there is not. Make the following cnages to make it work again:

// Change this:
HEU_TerrainUtility.GetAttributeTile(session, nodeID, scatterInstancerParts.id, out terrainTile);
//To this:
HEU_TerrainUtility.GetAttributeTile(session, nodeID, 0, out terrainTile);

This change makes it always fetch data regarding the tile number from Part 0 where the data is.

Side FX plz.. Terrains are usually the foundation of a pipeline. Please test before releasing.
User Avatar
Member
11 posts
Joined: July 2023
Online
Are you also having issues with grass/details? I cannot for the life of me get grass to appear on the terrain ... it creates prototypes in the inspector properly, and you can select one and manually paint it on the terrain just fine. But no amount of finesse seems to get it to work from Houdini. If I have to hand paint grass on every piece of terrain (which I'm not so good at, and have a shaky hand from reconstructive surgery) then it sort of kills my workflow and tanks my game concept ... also experiencing a LOT of instability and crashes of both editors, freezes/deadlocks, etc. I think the plugin is just badly in need of maintenance and modernization and Unreal has basically been getting 100% of the attention (Unity just sort of casually mentioned in passing now and again) ...

If SideFx is willing to give the Unity plugin some love and care, I will help out and contribute ...
"Make it exist ..."
User Avatar
Member
11 posts
Joined: July 2023
Online
This is probably what's causing my tree scattering hell in Unity 6 with the latest plugin ... I have done so much hunting and research and troubleshooting I forgot about this post. But now Jetbrains Rider is broken and won't find the "GenerateTerrainBuffers" function. What file is this in?

EDIT:
I found the method in question and made the suggested changes, but it still doesn't work. I added some log statements to try to get some info/feedback, but nothing ever shows in the console. Then I enabled the debugger and set breakpoints ... it never gets called. I tried experimenting with input nodes and heightfields and had all sorts of crazy bugs, like the scene view camera getting deleted and scene tab popping up in another window but not working and throwing 1,000 exceptions, or the input node's input fields disappearing ... there's apparently a lot of bad stuff happening ...
Edited by arkaen - April 1, 2024 02:35:30
"Make it exist ..."
  • Quick Links