How to make a clean uv grid out of this?

   666   6   1
User Avatar
Member
67 posts
Joined: April 2019
Offline
Hi,

I have some geometry could be thought of as a grid with 16 points across and 5 points in height, although the geometry is distorted and the point numbers are quite sequential.

I'm trying to get the uvs for this geometry to be in that 16 x 5 grid layout, fitting neatly into the 0-1 uv space, but I can't work out how to do it.

That is, I'm trying to go from this:



To this:



Does anyone have any suggestions on how this could be done procedurally?

Thanks

Attachments:
uvs.jpg (591.5 KB)
uvs-goal.jpg (540.2 KB)

User Avatar
Member
1662 posts
Joined: March 2009
Offline
If (only if, though) your ordering is guaranteed, you can treat it as a mesh. ConvertSOP set to mesh, then a UvtextureSOP with the type parameter set to "Rows & Columns", then ConvertSOP back to polygons.

This should do it, for this special case.
Martin Winkler
money man at Alarmstart Germany
User Avatar
Member
67 posts
Joined: April 2019
Offline
Thanks,

Unfortunately the ConvertSOP is messing up the geometry.

I'm guessing this is because the point numbers are in the correct order?
User Avatar
Member
698 posts
Joined: Feb. 2017
Offline
I recommend this hda to gridify uvs.
https://www.orbolt.com/asset/mifth::mifth_uv_grid

Cheers
CYTE
Edited by CYTE - April 14, 2024 08:34:37
User Avatar
Member
67 posts
Joined: April 2019
Offline
Still no joy unfortunately.

I think the issue with all of the suggested methods might be the point ordering on the geometry.

I've tried to change the ordering to match a grid but it's never quite right.

The closest I've come to getting the right point order is to sort points by x position, but due to the shape of the geo the ordering flips half way through.

I've attached the original geometry in case anyone wanted to try to crack it.

Any help is most appreciated.

Thanks

Image Not Found

Attachments:
uv_grid.hiplc (95.8 KB)

User Avatar
Member
33 posts
Joined: July 2022
Offline
I have a way, wait for me, as long as I understand your needs correctly
------
I came late for some reason, and I hope I am right

If you delete "autouv 1" "attribpromote 1" "attribwrangle 1", the result should also be correct
Edited by juejuezi - April 14, 2024 12:24:24

Attachments:
PixPin_2024-04-15_00-17-49.png (994.6 KB)
uv_grid.hiplc (167.5 KB)

User Avatar
Member
67 posts
Joined: April 2019
Offline
Thank you so much juejuezi.

That does indeed appear to solve it!

Now I just need to go through it carefully to understand how it's solving it

Most appreciated.

Thanks.
  • Quick Links