ncic

ncic

About Me

Expertise
Not Specified
Location
Not Specified
Website

Connect

Recent Forum Posts

mac weirdness, only me? March 16, 2010, 10:28 p.m.

ive reported these bugs to sidefx and they are checking it out. nice.

with this post i just want to see if anyone else is having the same or any of the problems im having.

i should point out i use tablet 99,9% of the time, so when i say click i mean a pen tablet click.
but ive reproduced the bugs with a mouse (except the translate plane one ofcourse)

i have 16gb ram and 8 procs on os 10.6.2, houdini 10 build 0.554

ok so here it goes

when i start houdini. if i press any key on my keyboard i get the system sound warning beep. everything still works fine but for every keyboard keypress i get this sound. its very strange.
so basically to make things clear im gonna describe a possible scenario upon houdini start:
i press tab (BEEP) to find an operation
i write(box) b (BEEP) o (BEEP) x (BEEP)
press enter (BEEP) to select box
press enter (BEEP) to center on the construction plane
hold space (BEEP) (BEEP) (BEEP) (BEEP) (BEEP) ….. to navigate viewport

until i do one of the following workarounds:
1) command-tab out to another application then back into houdini and it disappears.
2) press any interface object like drop-down, tab, or icon anything clickable.
3) log out of system user, and the first start of houdini for that login this bug is not there, i get no warning beep. but if i quit houdini and start it again it gives the warning sound every time until i do one of the workarounds above or log out and start houdini.

houdni seems to lose connectivity with the keyboard every time ive used a drop down menu, wheter it is in the scene after right clicking or a drop down lets say in the parameters window or network window.

the workaround to make it active again is simple, i just need to click somewhere in the interface like on the sides or just cmd tab out to another application and back again, and everything works fine, keybaord shortcuts work and i can now press space to navigate and such.

its a simple workaround but having to do that after every drop down menu operation is a bit tough on my nerves. i usually forget to do it and end up deselecting stuff.

to be a bit more clear.
by drop down menu i mean like, for example, a right click in the scene view and choosing “accept selection”.
after done that i press space and i do not get the hand to navigate the viewport.
i press tab and i dont get the tab menu.
if i do a cmd z to undo it doesn work, because everything keyboard operation seems deactivated
the mouse pointer works.
i can only deselect or make a new selection in this state.

same thing happens when maximise view with cmd B
the scene turns all white, and i have to click somewhere in the interface outskirts or switch application and back to make scene view active again.

another weird drop down issue is in the camera paramters under the view tab.
the drop down for resolution works as normal only once. after used it once i need to use the arrows to be able to switch between the resolutions.

the scene view drop down where i select “look through” for lights and camera does not always respond.

sometimes the ladder gets stuck when i middle click drag.

ctrl double clicking on the axis handles with my tablet pen doesnt give me a translate plane. i have to use the mouse to get it to work or right click and use the drop down.

“cmd ,” to get preferences up has never worked for me even if it gets hightlihted with blue in the menu.

i get atleast two houdini fatal error crashes per hour

ill end this with some common console errors:
2010-03-15 15 mar 04.49.17 .com.sidefx.Houdini objc: ALT HANDLERS: *** over 1000 alt handlers installed; this is probably a bug

2010-03-15 15 mar 04.49.18 .com.sidefx.Houdini 10286: Fatal error: Segmentation Fault

2010-03-15 15 mar 04.49.18 .com.sidefx.Houdini (sent by pid 0)

2010-03-15 15 mar 04.49.19 houdini Error loading /Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin/Contents/MacOS/DVCPROHDAudio: dlopen(/Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin/Contents/MacOS/DVCPROHDAudio, 262): no suitable image found. Did find:
/Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin/Contents/MacOS/DVCPROHDAudio: no matching architecture in universal wrapper

2010-03-15 15 mar 04.49.19 houdini Cannot find function pointer NewPlugIn for factory C5A4CE5B-0BB8-11D8-9D75-0003939615B6 in CFBundle/CFPlugIn 0x200280940 </Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin> (bundle, not loaded)

2010-03-15 15 mar 04.49.19 com.apple.launchd.peruser.501 (.com.sidefx.Houdini) Exited with exit code: 139


2010-03-15 15 mar 04.49.24 houdini invalid drawable

2010-03-15 15 mar 06.29.28 .com.sidefx.Houdini WARNING: The -background flag is not supported on OS X. Ignoring it…

2010-03-15 15 mar 06.33.38 .com.sidefx.Houdini colorwheel1 evalInt: Invalid parameter name usecomp




wow, longer post than i had planned, thanks for reading.

can't render image sequence anymore Jan. 14, 2010, 2:48 p.m.

ok, i got the reply now
so, i had not named my file sequence correctly, how stupid of me ops:
maybe youre doing the same thing
just in case you dont know you need to add $F to the name
instead of filename.png write filename_$F.png
that way each frame will get a unique file name and will not overwrite the previous.
filename_1.png filename_2.png and so on
ops:

can't render image sequence anymore Jan. 14, 2010, 2:09 p.m.

ah ok then probably just a temporary bug. i reported it yesterday and today i sent my .hipnc to sidex so lets hope they can track it down soon.