Recieving shadows without self-shadowing

   9034   4   3
User Avatar
Member
153 posts
Joined: Dec. 2009
Offline
Apollogies, if I'm overseeing something obvious…

How is it possible to let an object recieve shadows casted by a specific object, avoiding self-shadowing. Right now, I am playing around with the shadowMatte material. Without success so far…

My goal is to integrate in post a new object into an already rendered sequence, lit by a sun light and a sky light.

I assume, this has to be done within the shader. But how?

Cheers,
Marc
User Avatar
Member
192 posts
Joined: Nov. 2008
Offline
just exclude the object you don't want to self-shadow from the shadow mask of the lights. for example, if the geometry you wanted to exclude were called “ground” you would set the shadow parameter to:


* ^ground
User Avatar
Member
153 posts
Joined: Dec. 2009
Offline
Um, well, that's exactly what I did. Thanks for that clarification! After I restarted houdini, the behaviour is as expected, again.
User Avatar
Member
173 posts
Joined: March 2014
Offline
hi, could someone point me the page on the manual where it's all explained.

something we write

“ primary -shadow & -reflection ”

another place we write

“ * ^sand ”

some place writing

“ toto @tata ” works, sometimes not …


is there a very great tutorial or a wiki where it's all demistified ??
User Avatar
Member
738 posts
Joined: April 2008
Offline
I've bumped in this not that old thread and see if anyone have the answer to what is the best way to disable self shadow.

Thanks!
http://www.vimeo.com/17790588 [www.vimeo.com]
  • Quick Links