Is Houdini 14 supported by Houdini Engine for Maya yet?

   3161   4   2
User Avatar
Member
3 posts
Joined: Feb. 2012
Offline
I'm getting an error when trying to load an asset from H14.

Is this supposed to work yet? If so, which Maya plugin supports Houdini 14's .hda format?

I tried “hfs_14.0.201.13/engine/maya/maya2014/plug-ins/houdiniEngine.so” and got the following error:

// Error: Invalid flag ‘-loadOTL’ //

Thoughts?
User Avatar
Member
556 posts
Joined: June 2006
Offline
i haven't test it but try to download the newest daily build…..

https://www.sidefx.com/index.php?option=com_download&Itemid=208 [sidefx.com]
User Avatar
Member
3 posts
Joined: Feb. 2012
Offline
I also just tried ‘hfs_14.0.247’ from Feb 14, still with no luck….

It's strange because Maya's file browser is only filtering for the ‘OTL’ format, and won't even recognize the .hda file.
awong
Member
818 posts
Joined: Sept. 2013
Offline
The Maya plug-in supports Houdini 14.0 right from the beginning.

Did you get the “-loadOTL” error from using the Houdini Engine menu? The flag was renamed to “-loadAsset” over a year ago. If it's called from a custom script, then you'd have to update the script.

If that error came from using the Houdini Engine menu, then the Maya plug-in might be using some old MEL scripts sitting in your system somewhere. The fact that the browser only shows .otl also suggests that the MEL scripts are from the wrong version. Try running this MEL command:
whatIs houdiniEngineCreateUI;
You should see a result like:
// Result: Mel procedure found in: /opt/hfs14.0.257/engine/maya/maya2014/scripts/houdiniEngineCreateUI.mel //
Note that houdiniEngineCreateUI.mel should be coming from the hfs14.0.257 directory. If it comes from some custom directory like /home/awong/maya/2014-x64/scripts, then those scripts are likely outdated. You would have to remove those MEL scripts so that the Maya plug-in can use the right version of the scripts.
Andrew / アンドリュー
User Avatar
Member
3 posts
Joined: Feb. 2012
Offline
Thanks awong. That identified the problem. It's pointing to the correct scripts now.

It's loading assets now.

Thanks again,

-m
  • Quick Links