Noisy point renders in Mantra

   5093   10   1
User Avatar
Member
32 posts
Joined: Dec. 2014
Offline
Hi Guys,

I'm trying to render a large number of dense points but can't seem to get rid of the noise that's obviously causing flicker from frame to frame - Except for using Mad pixel samples, anyone have any tips for rendering this kind of thing without killing the render times?

I've attached a simple file to show what I'm getting frame to frame.

Any advice would be much appreciated

Attachments:
points render.hipnc (251.3 KB)

Kind Regards,

Ben
User Avatar
Member
166 posts
Joined: March 2013
Offline
I don't know why SESI hided this parameter in H14, but add Jitter (vm_jitter) to your Mantra ROP. Edit Rendering parameters -> Mantra -> Sampling. Then set this parameter to 0 (zero).

By default Mantra will jitter the pixel samples to combat “stair-stepping”, resulting in jittery noise. This jitter will take quite a lot of pixel samples to get rid off - if ever. This jitter is usually VERY noticable in highlights and such.

Setting this parameter to 0 will take each pixel sample at the same location every time, resulting in practically no jitter at all. However it might introduce some stairstepping (probably a non-issue regarding particles), so if you get that just turn up your pixel samples a bit to resolve it. With the settings for production quality it usually won't show up.

Why this isn't default I don't know, since it produces a lot better renders overall. I hope it helped
User Avatar
Member
32 posts
Joined: Dec. 2014
Offline
Thanks Skybar, I gave it a shot but that doesn't seem to change anything, the ONLY thing that seems to help is CRAZY pixel samples which is going to make things very hard to deal with in terms of render times.

Maybe my expectations were too high, not sure.

Thanks for the advice though, much appreciated.
Kind Regards,

Ben
User Avatar
Member
166 posts
Joined: March 2013
Offline
Are you sure? Try this hip. Render the first frame, snapshot it and then render the second frame. Compare those. The difference is really tiny atleast on my end. I just added the Jitter parameter and bumped pixel samples to 5x5.

Attachments:
points_render_dv.hipnc (232.6 KB)

User Avatar
Member
32 posts
Joined: Dec. 2014
Offline
Sorry mate, yes you're correct. The file I posted was showing an issue with the static points jittering which I later fixed by enabling sample lock OR using your method.

Once I affect these points in pops with forces etc. …the noisefest kicks back in, looks to be something weird going on with the samples / shading of such dense volumes of points moving around.
Kind Regards,

Ben
User Avatar
Member
2624 posts
Joined: Aug. 2006
Offline
Isn't jitter on by default under the hood ? . I noted that the transparent stochastic sampling is on by default, one effects the other doesn't it ? .

rob
Gone fishing
User Avatar
Member
4172 posts
Joined: June 2012
Offline
Most likely the tiny points are only a few pixels in rasterised camera space, so you need a good spatial resolution to lessen the aliasing when the pixels are binned down to a single pixel. Increaseing Pixel Samples does this.

Simply drop the other sample rates to compensate and/or use Deep compositing for this points pass.
User Avatar
Member
196 posts
Joined: July 2007
Offline
You got some good info here about your problem, and how to solve it.

Here is one more idea that you can try, using Raytrace and deepshadow maps

Attachments:
points_ren.mov (4.7 MB)
points_render.hipnc (653.7 KB)

WEB
http://www.igorfx.com/ [igorfx.com]

Vimeo
https://vimeo.com/igorzanic [vimeo.com]
User Avatar
Member
166 posts
Joined: March 2013
Offline
circusmonkey
Isn't jitter on by default under the hood ? . I noted that the transparent stochastic sampling is on by default, one effects the other doesn't it ? .

rob
Yes, the pixel sample jitter is on (set to 1) by default “under the hood”. Which usually is bad. Whenever you get jittery highlights this is the problem. I've done some extensive testing on this, and to get rid of jittering/creeping highlights you either need to crank pixel samples really high, which may or may not solve it while taking considerably longer - or turn off this jitter. Although the testing I did was related to highlights on objects, not particles - so there might be a better workflow regarding to that.

I don't know what you mean by this affecting stochastic sampling, that is only used for volumes/transparent objects?
User Avatar
Member
595 posts
Joined: May 2007
Offline
Yet another thing that can help with flickering particles is vm_geofilterwidth. If a point's size is smaller than this value in raster space, say, one pixel, the point is scaled to the value specified and it's transparency modified to compensate.

E.g. if you have an opacity 1.0 particle the size of 1/100th of a pixel, it will be shaded as a particle the size of one pixel but opacity of 0.01
User Avatar
Member
32 posts
Joined: Dec. 2014
Offline
Cheers guys, thanks for all the advice. I'll jump into Houdini tomorrow and put these ideas in place & see if I can get these particle animations to come out clean
Kind Regards,

Ben
  • Quick Links