HAPI Error

   7830   15   2
User Avatar
Member
14 posts
Joined: March 2015
Offline
Hi! I've got a problem getting my assets into the scene. Everytime I want to set an asset I get the following error:


Houdini License issue - (HoudiniAssetActor_9) : (HAPI Error: No Valid Licenses Found
- HAPI_LICENSE_MODE unset or is set to ‘default’ meaning Houdini Engine will first try to acquire a Houdini Engine license and if one is not found it will try to acquire an interactive Houdini license (Houdini then Houdini FX).
- Unreal Plugin Trial Has Expired
- No Houdini Engine license found.
- No Houdini license.
- Found a Houdini FX (Houdini Master) license but it is not the required commercial variant.
- No Houdini Engine Indie license found.
- No Houdini Indie license.).


Two days ago everything worked fine. I've got the apprentice edition but actually this shouldn't be a problem with the beta?

Thanks!
User Avatar
Member
111 posts
Joined: Aug. 2014
Offline
I got this too, I hope the beta period for testing isn't this short…
User Avatar
Member
173 posts
Joined: April 2014
Offline
Hello!

Could you please update to a newer version of Houdini 14? It should solve this problem.

Thanks
User Avatar
Member
111 posts
Joined: Aug. 2014
Offline
I'm using build 291, do I need to use a daily build? I reinstalled 291 and deleted the houdini engine folder in UE4 and re copied the folder from the fresh install. Still getting the same error as OP.
User Avatar
Member
14 posts
Joined: March 2015
Offline
I just installed the daily build and now it works again.
Thanks!
User Avatar
Member
173 posts
Joined: April 2014
Offline
You can use one of the latest daily builds. We will also have next production build this week.

Thanks!
User Avatar
Member
111 posts
Joined: Aug. 2014
Offline
yep, working with daily, thanks!
User Avatar
Member
1 posts
Joined: Sept. 2014
Offline
I updated to 14.0.291 and installed the first rendition of spookytable into unreal engine. Unfortunately it didn't render any of the textures, and then today, (I hadn't used it for a while I got the hapi licence error). I updated to 14.0.335, and now I have a textured table - I think because of the unreal shaders update. Thanks that is what stopped me from going down this path further for using houdini for assets. I appear to only have 2 issues now;
1. the table is like a u shaped table (spooky table - see attached image (this is from unreal engine btw)) - there is a rectangle missing from 1/2 of it, so it appears as a U with chairs all around, I did a reset parameters, rebuild assett & recook, but it didn't correct it.
2. I saved my scene and then reopened (with table in), and when I reopened, the table stayed unrendered (no textures), if I recook the asset, it comes in fine, but if I have a bunch of houdini assets, that's not ideal, is there a better way to do this?

I'm curious if I upgrade to indy prior to the end of the unreal plugin trial period, will I still be able to access the unreal plugin within the indy version.

Many Thanks,
Dave

Attachments:
Capture.JPG (48.1 KB)

User Avatar
Member
11 posts
Joined: July 2015
Offline
I have downloaded the lastes version 14.0.393 build UE4 and when i import the asset into unreal i get

Houdini License issue - (HoudiniAssetActor_1) : (HAPI Error: No Valid Licenses Found
- HAPI_LICENSE_MODE unset or is set to ‘default’ meaning Houdini Engine will first try to acquire a Houdini Engine license and if one is not found it will try to acquire an interactive Houdini license (Houdini then Houdini FX).
- Unreal Plugin Trial Has Expired
- No Houdini Engine license found.
- No Houdini license.
- Found a Houdini FX (Houdini Master) license but it is not the required commercial variant.
- No Houdini Engine Indie license found.
- No Houdini Indie license.).
Juan Camilo Acosta Arango
ja0335@gmail.com
User Avatar
Member
402 posts
Joined: March 2013
Offline
From the line:
Unreal Plugin Trial Has Expired
It seems that the plugin is still using an older installation of Houdini than the 393 you installed.

To make sure you're using the correct plugin/Houdini version, go to:
C:\Program Files\Side Effects Software\Houdini 14.0.393\engine\unreal\4.8
and copy the HoudiniEngine folder. Now go to:
C:\Program Files\Epic Games\4.8\Engine\Plugins\Runtime
delete the HoudiniEngine folder there if it exists, and paste the folder you copied.

Now restart Unreal 4.8 and go to Edit > Project Settings, scroll down to Plugins and select Houdini Engine. In the Houdini Engine settings screen, scroll to the bottom to Plugin Information and make sure the versions there list 14.0.393.
User Avatar
Member
11 posts
Joined: July 2015
Offline
I have uninstalled Houdini and reinstalled it. Copyed the Folder in to the forlder you said, recomplie but the same error was thrown when trying to put in the scene the houdini asset.

I've confirmed the version into unreal an its ok. I have checked the liscense server to see if it is running and yes.

I must say I'm using the Aprenticce Version, it stills having support for UE4?

Attachments:
Plugin.PNG (11.6 KB)

Juan Camilo Acosta Arango
ja0335@gmail.com
User Avatar
Member
402 posts
Joined: March 2013
Offline
Hmm. Apprentice should work as long as the Houdini build is new enough. The only other thing I can think of is that your system date is wrong - not set to today's date?
User Avatar
Member
11 posts
Joined: July 2015
Offline
Yes, it is Ok… :cry:
Juan Camilo Acosta Arango
ja0335@gmail.com
User Avatar
Member
402 posts
Joined: March 2013
Offline
Can you confirm you're still getting the exact same error after copying the HoudiniEngine folder over and making sure 393 is now being used?

Also, you mentioned compilation. How are you compiling? Do you have Unreal 4.8 installed via the Epic Games Launcher or are you compiling all of Unreal from source? If you're using the Launcher, can you try just launching a default blueprint project from there and try to load a Houdini asset?
User Avatar
Member
11 posts
Joined: July 2015
Offline
I downloaded 4.8.0 from the launcher pasted the Houdini Folder in the specified location, but now i have an error saying “The HoudiniEngienRuntime appears to be from another version”.

I tried with the 4.7 ue4 version and it works!!! So for now i will work with it.
Juan Camilo Acosta Arango
ja0335@gmail.com
User Avatar
Member
402 posts
Joined: March 2013
Offline
Try today's production build, 14.0.395. It should have that 4.8 “from another version” error fixed.
  • Quick Links