weird bug in Dops

   2690   5   2
User Avatar
Member
101 posts
Joined: Feb. 2015
Offline
Actually I don't know if it a bug or what but …

I have a relatively simple set up (see attached file). I tried to expand on Peter Quint tutorial [youtube.com] , a nice peeling effect.

Peter uses some magnet force on his video. Which works fine. I tried to introduce some wind using an external velocity field. The problem is this field will have no effect what so ever until I remove all the collisions in the sim. Even with a simple ground plane, wind doesn't have an affect. I don't understand why this happens. Does anybody have a clue ?

Edited by gui2one - May 23, 2016 12:31:39

Attachments:
thingy_dops_01.hiplc (1.6 MB)

https://vimeo.com/user43710534 [vimeo.com]
User Avatar
Member
101 posts
Joined: Feb. 2015
Offline
Really ?
Am I the only one with this issue ?
https://vimeo.com/user43710534 [vimeo.com]
User Avatar
Staff
2540 posts
Joined: July 2005
Offline
When you are working with cloth and deforming colliders, immediately increase the quality of the collider and increase collision passes on the cloth solver.

I did both to your scene and I get tearing cloth with colliders enabled. Nice file btw.


With the deforming collider, I always turn off geometry and turn on surface collision geometry (with volume collider absolutely off for cloth) and of course turn off display other objects in the viewport. Then I play forward and and inspect the collision geometry (bypassing all other solvers to see in real time). In your case the Geometry Representation set to Concave gave good results on the deforming geometry as I play forward.

Just a quick note on Concave colliders. This works good on a hand full of complex colliders. If you have thousands or more, this will have a large overhead. Concave is to be used on a handful of colliders at this time (H15.5).


With the Cloth in FEM Solver, when you have cloth colliding against a complex collider (deforming) in this case, always increase the collision passes to help the solver resolve the collisions and keep the cloth from being trapped in the collider as was happening in your scene.


Hope this gets you going.

Attachments:
thingy_dops_01_jw.hiplc (596.6 KB)

There's at least one school like the old school!
User Avatar
Staff
2540 posts
Joined: July 2005
Offline
Oh and gentle reminders work best imho.

I'm pretty busy these days…
There's at least one school like the old school!
User Avatar
Member
101 posts
Joined: Feb. 2015
Offline
jeff
Oh and gentle reminders work best imho.

I'm pretty busy these days…

Sorry, I didn't mean to be rude.
Thanks a lot for the tips
https://vimeo.com/user43710534 [vimeo.com]
User Avatar
Member
6 posts
Joined: Jan. 2015
Offline
Hi,
I've downloaded Jeff's example file and yet when the output flag is set to include the static collider, the wind has no effect on the cloth. If I move the output flag anywhere above “merge3” on the cloth side excluding the collider, the wind works fine.

Anyone else experiencing this behavior? Is it a bug?

I've tried on H15.5.717 and H16.0.633.

Thanks
Yaniv
  • Quick Links