Asset Generator ignores Enabled check

   797   4   0
User Avatar
Member
9 posts
Joined: Dec. 2015
Offline
Hello,

I started making assets for our pipeline and I noticed that they get calculated even if you have its generator enabled thick set to off. It does hide the result but it still does the cooking, even at render time. You basically have to break the asset with inputing wrong file path (if it has one) or removing the object from link field, now imagine having several of them in the scene.

I tried reporting this to maxon support by they are dissing me that this is not a bug and if the thick is off then generator will not work…

This is really frustrating and I have no idea to whom to turn, so I am writing here.

This happens on all my assets even on voronoi fractures one from orbolt.

I hope this can get to the developers somehow, it certainly wont by maxon support.

Thanks,

Sandi
Edited by ratata - Aug. 28, 2017 11:58:29

Attachments:
asset_01.png (445.5 KB)

User Avatar
Member
340 posts
Joined: June 2008
Offline
Hey Sandi,
this is a known Limitation currently, but there's a simple way to circumvent it if you're making your own Assets:
Add a Switch node at the end of your Houdini Setup, and feed a simple object (Box for example) in the First Port and your final Output in the Second port.
Drag the “Select Input” in your interface and set the “Type” to “Toggle” (radio button), and name it appropriately (e.g. “Active”)
This will appear in your Asset interface in C4D, and Deactivating it, will deactivate the whole Asset.
sample asset attached.

Hope this helps

Attachments:
disable_switch_01A.hda (10.3 KB)

User Avatar
Member
340 posts
Joined: June 2008
Offline
one added note. You can expand on this technique, by bypassing all “expensive” calculations on your asset to the “Deactivated” state, so you can control what is visible.
For example, you have a complex fluid simulation, that uses 2 input objects, one for emitter, and one for a fluid container.
You could circumvent the simulation, and show only the Main objects in the “Deactivated” state.
You can have even more control, but setting switches along your setup, creating a “granular” approach to this.
So, if an asset has 3 - 4 heavy calculation areas, you could have 3 - 4 switches, each one turning on and off parts of your asset.

I think I'll make a tutorial on this :-)

Cheers
Edited by noseman - Aug. 30, 2017 10:49:55
User Avatar
Member
9 posts
Joined: Dec. 2015
Offline
Yeah, I did eventually resort to this and then link enabled thick to it by xpresso…

Thanks!
User Avatar
Member
340 posts
Joined: June 2008
Offline
just to keep things in order, here's the vimeo link to a tutorial on how to do this.
Thanks again Sandi for posting the question.
https://vimeo.com/231731383 [vimeo.com]
  • Quick Links