MotionVectors not working with Volumemix nodes

   191   4   1
User Avatar
Member
10 posts
Joined: Nov. 2017
Offline
Hi Mike Thanks for the great GameDev tools,

I've been using the Motion Vector tool on my simulations without any problems. However, I started to do some looping simulations where I use a volumemix node, but now the tool does not work. I can export the packed texture using the texturesheets tool, but the motion vector tool will only output pure black in the RGB now. I have attached a sample pic here of the node info:

Node Details [imgur.com]

I'm also fairly new to houdini and figuring it out as I go, so if I'm doing something super wrong let me. Thanks again!

Edited by Devero - Feb. 6, 2018 16:35:38

Attachments:
MotionVectorsIssue1.jpg (705.4 KB)

User Avatar
Staff
66 posts
Joined: May 2017
Offline
Looks like that should work. Can you confirm that you're getting a working velocity field out of the volumemix by using a scatter and a volume trail?

Attachments:
volume_trail.jpeg (212.8 KB)

User Avatar
Member
10 posts
Joined: Nov. 2017
Offline
Hi Mike,

Thanks for the quick reply, I have attached the pic but it looks like i'm getting the velocity field here:

Edited by Devero - Feb. 6, 2018 16:35:28

Attachments:
Volumetrail1.jpg (496.0 KB)

User Avatar
Staff
66 posts
Joined: May 2017
Offline
That trail doesn't look too promising. The lines should be following the velocity field in the volume. Those lines for the most part are just pointing straight up. Is there reason you're using the destination and source premult to blend the volumes instead of the blend parm?
User Avatar
Member
10 posts
Joined: Nov. 2017
Offline
It was just a technique I had found online while trying to learn volume Mixing. I did go ahead and switch to using the Blend Parameter, by setting keys at 0,1,0 during the sequence and it looks the same.

However, I went ahead and bypassed the “DOP Import” node and hooked directly to the “Dop I/O” node and was able to generate a better vector field plus the motion vector render looks like it should now.

Curious on why it wasn't working through the other node, i'm not able to render the emission layer if I do it this new way, but if i revert to going through the other way, the emission layer does render correctly. For my quick fix it seems, when I want to render out the packed maps with the emission, i need to hook up to the “Dop Import” and then if I want to render out the MotionVector texture I'll just have to switch it to the “Dop I/O” field. Unless there is another suggested way of doing it or a way to make the emission layer render.

Thanks again for the help.

Edited by Devero - Feb. 6, 2018 16:35:20

Attachments:
updatednodes.jpg (946.9 KB)

  • Quick Links