fluid vertex animation shader not working with Universal Windows Platform

   603   10   0
User Avatar
Member
6 posts
Joined: Feb. 2017
Offline
I'm trying to use the vertex animation shader provided in the game dev tools, everything works perfectly in standard PC build but the instant I switch to Universal Windows Platform, everything gets really weird. the animations still happen but the model acts like its trying to animate around a square in the center. In the screenshot I have a “melt object” straight from Houdini that should be completely flat but this is the result. Does anyone have any ideas on how to fix this?

Attachments:
Capture.PNG (62.3 KB)

User Avatar
Staff
124 posts
Joined: May 2017
Offline
Try turning Export for Mobile option on in the vertex animation texture exporter tool.
Edited by seelanv - April 6, 2018 15:36:08
User Avatar
Member
6 posts
Joined: Feb. 2017
Offline
seelanv
Try turning Export for Mobile option on in the vertex animation texture exporter tool.
Unfortunately, that had the exact same results.
User Avatar
Staff
124 posts
Joined: May 2017
Offline
Could you attach a simplified version of your project with the problem and relevant files?
User Avatar
Member
6 posts
Joined: Feb. 2017
Offline
Heres a zip of my a simplified version of my project. I added the .hip file to the main assets folder

Attachments:
Vertex Shader Example.zip (14.8 MB)

User Avatar
Staff
124 posts
Joined: May 2017
Offline
Thanks for attaching the example. Looks like Unity is converting the texture from RGBA Half (16-bit per pixel) to RGBA 32-bit automatically when going from Standard PC build to UWP. The conversion is most likely losing the required data. Try re-exporting from the Vertex Animation Texture tool as TGA instead, with Export for Mobile turned on. Also make sure to set import settings such that power of 2 is none or disabled, wrap mode to repeat, filter mode to point, and compression to None.
User Avatar
Member
6 posts
Joined: Feb. 2017
Offline
seelanv
Thanks for attaching the example. Looks like Unity is converting the texture from RGBA Half (16-bit per pixel) to RGBA 32-bit automatically when going from Standard PC build to UWP. The conversion is most likely losing the required data. Try re-exporting from the Vertex Animation Texture tool as TGA instead, with Export for Mobile turned on. Also make sure to set import settings such that power of 2 is none or disabled, wrap mode to repeat, filter mode to point, and compression to None.

I tried your suggestion and the result was better but it still doesnt look quite right.
Edited by Fuzzinator1234 - April 16, 2018 12:23:34

Attachments:
Capture.PNG (71.3 KB)
Capture2.PNG (124.4 KB)

User Avatar
Staff
124 posts
Joined: May 2017
Offline
Attach your textures please.
User Avatar
Member
6 posts
Joined: Feb. 2017
Offline
currently im only using the displacemap

Attachments:
Liquify.tga (1.0 MB)

User Avatar
Staff
124 posts
Joined: May 2017
Offline
I tried using the new texture but looks like the parameters aren't correct, or need the other generated files as well. Could you attach your entire project?
User Avatar
Member
6 posts
Joined: Feb. 2017
Offline
Not to worry I was finally able to get it working. I used the .exr default for the export textures and used the import override option on the texture to force it to import the texture under the RGBA Half setting.
  • Quick Links