Can't get particles to appear in HDA!!

   309   2   0
User Avatar
Member
10 posts
Joined: Jan. 2018
Offline
I've set up a particle fluid tank asset similar to the one Noseman featured in his Siggraph 2015 Rewind available here - http://www.cineversity.com/vidplaytut/siggraph_2015_rewind_athanasios_pozantzis_houdini_and_cinema_4d_r17 [www.cineversity.com]

My network ends with 5 geo nodes: 4 which export the different point groups (water, foam, spray, and bubbles) with their own color.
And the last is a RBD sphere used for collision. That network ends in a dop import sop.

No matter how I open my asset in Cinema 4D, I don't see my particles. I've read about the issue where at least one particle needs to exist at frame 1 in order for it to work, but all the particles in my FLIP tank exist at frame one, so I'm unsure of the issue.

In Cinema 4D, I experience a number of things. The asset imports green, but nothing is visible in viewport, not even the collision object. In previous imports, I could see the collision object, but no particles. Sometimes, the asset imports a number of particle geometry objects that, nevertheless, don't really correspond with the groups I've created. However, never any particles.

I've also checked that everything in the asset uses relative paths.

Any ideas?
Edited by amschuppel - June 13, 2018 14:59:22

Attachments:
troubleshoot.JPG (276.6 KB)
troubleshoot2.JPG (77.7 KB)

User Avatar
Member
10 posts
Joined: Jan. 2018
Offline
UPDATE. I've done some cleaning up and I've made progress. I've added an arbitrary point to the end of every particle group output and now all 4 groups are recognized inside of Cinema. I've also done some digging and found some stray non-relative paths. I've fixed those up and now I have my object visible.

My asset looks perfect in the object manager, but still no particles. I hope this help narrows down my issue.

Attachments:
troubleshoot3.JPG (80.2 KB)

User Avatar
Member
10 posts
Joined: Jan. 2018
Offline
I've since fixed the issue. I believe I was deleting with the clean sop certain attributes that Cinema needed in order to read the points as particles.

Here is the magical note from Noseman I would I could've found earlier:

One more thing I need to explain..
Unless your Houdini Particles have an “id” attribute, they won't load in C4D.
You can append an “id” using an “Attribute Create”, set it to “integer” and make the expression “$PT”.
That way C4D has a global particle id (essential to C4D) and will load properly.
Don't forget to increase the Max TP count in the TP preferences.
Flip Tanks have an “id” on by default, but whitewater doesn't. Neither do simple point objects, so make sure you have the “id”.
Edited by amschuppel - June 13, 2018 18:04:01
  • Quick Links