Vertex Animation Shader - Unreal 4.20.1 for iOS 11.4.1

   599   6   1
User Avatar
Member
7 posts
Joined: June 2015
Offline
Hello,

I'm currently using Houdini 16.5.536 (Game Tools version 1.30), Unreal Engine 4.20.1 and building for iOS 11.4.1.

As a test I took a grid and added a sine wave to it in houdini.

Which works fine in the editor but when I launch it onto my phone it looks like this


I've taken a look at the examples given at GDC 2017 to make sure I had the correct import settings for the picture files. I've also added the hip file, just in case.
Edited by Ben Read - Aug. 8, 2018 22:13:51

Attachments:
picture_from_iPhone_7_plus.png (1.8 MB)
UE4_test_iOS.hipnc (1.7 MB)
sine_wave_UE4.mov (4.6 MB)

User Avatar
Staff
152 posts
Joined: Nov. 2012
Offline
Hey Ben,

I'm not super familiar with mobile development, but do you have any settings to control which version of opengl the mobile shaders compile to? My guess is that it's falling back to an earlier shader model that doesn't support reading textures in the vertex shader.

We have customers that have shipped mobile games with the vertex animation textures, so I know it's possible. But I'm not sure about Unreal and their mobile fallback settings.

Luiz
Luiz Kruel
Senior Technical Artist
SideFX
User Avatar
Member
7 posts
Joined: June 2015
Offline
Thanks for the response Luiz,

My unreal settings for rendering on iOS.


In houdini I also tried it with the export for mobile option turned on and it didn't seem to change anything when exported to the iPhone 7 plus.

These are the iOS material settings that are currently unchanged in Unreal Engine 4.
Edited by Ben Read - Aug. 14, 2018 20:44:36

Attachments:
iOS_rendering_settings.png (73.1 KB)
iOS_material_settings.png (84.9 KB)

User Avatar
Member
7 posts
Joined: June 2015
Offline
One thing I did find out, that is probably more of an UE4 issue, but UE4 isn't compiling code for Metal SM5.

This is what I get when I ask UE4 to compile shader code for the material that was generated from Houdini using the Metal SM5 API.


Everything else (i.e.: openGL, Vulkan) compile fine
Edited by Ben Read - Aug. 14, 2018 20:44:27

Attachments:
Metal_SM5_no_shader_code.png (108.7 KB)

User Avatar
Staff
152 posts
Joined: Nov. 2012
Offline
Yeah.. that's odd, you might want to post on Unreal's forums if you haven't already. I'm not familiar enough with mobile ue4 to point you in the right direction. Sorry about that
Luiz Kruel
Senior Technical Artist
SideFX
User Avatar
Member
2 posts
Joined: Feb. 2017
Offline
Hi. I do not know if it will help, you can export the map in .png format, not .exr. When I did a poison simulation in Houdini and export this in Unity (like Fluid, changed topology) - .exr it is look worse then .png
User Avatar
Member
7 posts
Joined: June 2015
Offline
Hello samoretyanin,

Thanks for your response. Unfortunately I got the same result, using both exr and png files. In relation to the forth post of this thread, Epic have noticed the code not showing as a bug and gave it the ID UE-63324. https://issues.unrealengine.com/issue/UE-63324 [issues.unrealengine.com]
  • Quick Links