UE4 plugin doesn't work for 17.0 on OSX

   259   3   0
User Avatar
Member
4 posts
Joined: May 2018
Offline
Hi,

I noticed that the UE4 plugin failed to find the correct dylib when starting up on macOS, it's expecting a folder in /Applications/Houdini/Houdini{version}/Frameworks/Houdini.framework/Versions/{version} but I only have /Applications/Houdini/Houdini{version}/Frameworks/Houdini.framework/Versions/Current when using the 17.0 installation.

Is this a known issue?
Edited by chrism - Oct. 12, 2018 11:06:27
User Avatar
Staff
286 posts
Joined: Sept. 2016
Offline
Hi

Yes, we're aware of that issue, as a workaround, you can set the directory manually in the project settings, under Houdini engine,
custom location.
User Avatar
Staff
286 posts
Joined: Sept. 2016
Offline
Hi,

This issue will be fixed in the next daily build of H17.0.
User Avatar
Staff
2117 posts
Joined: Sept. 2007
Offline
andcesaro
Hi,

I noticed that the UE4 plugin failed to find the correct dylib when starting up on macOS, it's expecting a folder in /Applications/Houdini/Houdini{version}/Frameworks/Houdini.framework/Versions/{version} but I only have /Applications/Houdini/Houdini{version}/Frameworks/Houdini.framework/Versions/Current when using the 17.0 installation.

Is this a known issue?

In Unreal: Edit > Project Settings > Plugins > Houdini Engine > Houdini Location - point it to the libraries directory at Applications/Houdini/Houdini17.0.352/Frameworks/Houdini.framework/Versions/Current/Libraries
Close and then re-open project. Then everything works.
Chris McSpurren
Senior Quality Assurance Specialist
SideFX
  • Quick Links