BakeTexure Rendering white

   99   3   0
User Avatar
Member
449 posts
Joined: Dec. 2013
Offline
Hi there,

I was just trying to get my head around bake texture and having a bit of trouble.
So I have an object in my scene that is rendering like this.


Then the bake renders white,


I'm just trying to render the lighting for this one object so I've left the other objects blank


Could that be causing the issues?

Thanks!
Pete

Attachments:
RenderTexture.hiplc (391.4 KB)

User Avatar
Staff
211 posts
Joined: Sept. 2016
Offline
Hi. You need to uncheck “Disable Lighting/Emission” (under Baking tab) to evaluate lighting. You should also un-set UV Cage Object in your attached scene. It's also very much recommended that you leave output picture in .rat format, and extract image planes to .tga (or whatever format, via “Extract Image Planes” under Images->Main tab)
User Avatar
Member
449 posts
Joined: Dec. 2013
Offline
Thanks @dlee!
The Disable Lighting/Emission was the one that was tripping me up
I'm still having a bit of trouble with the actual file export though. I set it to rat and added an extra plane but it doesn't seem to write out a usable file.


If you have a sec, I updated the file.

Thanks!
Pete

Attachments:
RenderTexture.hiplc (491.2 KB)

User Avatar
Staff
211 posts
Joined: Sept. 2016
Offline
If you enable “Extract Image Planes” (under Images->Main tab), it will pull image planes inside the .rat file in selected extract format and put it the same path as the .rat output picture.
By default it will extract the beauty/Cf+Af plane even if you haven't enabled any quickplanes (the convenience toggles right under the “extract format” dropdown). The reason why extra image plane with “all_comp” doesn't work is because it's for per-component output and the component list is empty. You can choose “direct” vex variable instead for indirect lighting, “indirect” for indirect lighting, or simply “Cf” if you want everything.
  • Quick Links