Fluid Vertex Animation Texture

   81   5   0
User Avatar
Member
3 posts
Joined: Nov. 2013
Offline
Hi,

I have an issue with Fluid Vertex Animation Texture. I am testing it using the source data from GDC2017, and exporting FBX and textures via Houdini 17.0.416 and Game Development Toolset 1.119 from Git, then import them into UE4.21.

Here is the picture what shows the issue I have. It looks like some vertices sampling wrong pixels of position map.



When I migrate Static mesh and textures from UE4 project file of GDC2017 into fresh UE4 project, it works. But if I export Static mesh as FBX, then import to fresh UE4 project, it doesn't work. So I am assuming something wrong with FBX importer in UE4.

Does anyone success to make Fluid VTA work in 4.21? Does it require to use any specific FBX import in UE4? Any suggestions are welcome.

Thanks,
Makoto
Edited by Makoto Tanaka - Feb. 13, 2019 11:54:43

Attachments:
vta.PNG (938.8 KB)

Framestore
User Avatar
Staff
171 posts
Joined: May 2017
Offline
Can you screen grab your import settings for the FBX in UE4?

And for the static mesh, in UE4, have you turned on “High Precision UV's” in the details panel?
User Avatar
Member
3 posts
Joined: Nov. 2013
Offline
Hi Mike,

Here is the screen grabs. I am just using default setting.




I didn't use “Use Full Precision UVs” when I import the static mesh, so I have enabled the option, then tried to import the mesh. But the tick mark of the option turned off as soon as I re-imported the mesh, so I am not sure the option is working properly.
Edited by Makoto Tanaka - Feb. 13, 2019 12:12:18

Attachments:
s1.PNG (80.3 KB)
s2.PNG (79.9 KB)

Framestore
User Avatar
Staff
171 posts
Joined: May 2017
Offline
You don't need to re-import after turning on “Use Full Precision UVs”. Just click on apply a little lower.

And I don't think this is an issue with the fluids but you generally want to turn on “replace” for Vertex Colour Import Options.
User Avatar
Member
3 posts
Joined: Nov. 2013
Offline
So do you think this is UE4 issue? Or my environment issue?

Also could you let me know which UE4 version you are using at SideFX for the debugging?
Edited by Makoto Tanaka - Feb. 13, 2019 12:37:47
Framestore
User Avatar
Staff
171 posts
Joined: May 2017
Offline
I've tested the VAT shaders recently in 4.19, 4.20 and 4.21. Besides a minor issue with the naming of bounding_min and bounding_max the export works correctly.

I doubt the issue is UE4. It's most likely your import or asset settings causing the issue.

For the mesh, make sure to turn off “Remove Degenerates” and change Vertex Colour import to “Replace”
For the static mesh settings, make sure you've turned on “Use Full Precision UVs”

For the textures, change:
Compression settings to Vector Displacement
Power of Two Mode to None
Filter to Nearest

If you've done all of that and it still doesn't work, check your material instance settings to make sure your bounding values are correct.
  • Quick Links