[SOLVED] Installation_check error and bad path to ImageMaigck/FFMPEG (on Windows)

   320   2   0
User Avatar
Member
363 posts
Joined: Feb. 2013
Offline
I get the follow error message when I {shift}+{V} on any node in Installation_check.hip
I opened the file via shelf>“TOPs Utils”>Installation Check
Note: “Zugriff verweigert” means “Access denied”

Error 
Error running callback 'onStartCook': [Error 5] Zugriff verweigert: u'C:/PROGRA~1/SIDEEF~1/HOUDIN~1.173/houdini/pdg/installation_check/pdgtemp'

Traceback (most recent call last):
File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.173/houdini/pdg/types\schedulers\local.py", line 195, in onStartCook
os.makedirs(self.tempDir(True))
File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.173/python27\lib\os.py", line 150, in makedirs
makedirs(head, mode)
File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.173/python27\lib\os.py", line 157, in makedirs
mkdir(name, mode)
WindowsError: [Error 5] Zugriff verweigert: u'C:/PROGRA~1/SIDEEF~1/HOUDIN~1.173/houdini/pdg/installation_check/pdgtemp'

Specs:
Windows 10 Home
Houdini Indie 17.5.173

Can I fix this, or should I check with support?


I also installed ImageMagick and added
PDG_IMAGEMAGICK="C:/Program Files/ImageMagick-7.0.8-Q16"
PDG_FFMPEG="C:/Program Files/ImageMagick-7.0.8-Q16"
to my environment variable file. Does this look correct? Do I need to add something else?
Edited by DASD - March 16, 2019 22:28:23
User Avatar
Staff
256 posts
Joined: Aug. 2017
Online
Hi, it looks like it is trying to create the pdgtemp directory but it's failing to because it's in C:\Program Files and doesn't have administrator privileges. You can work around this by copying the installation check folder to somewhere else or using the merge into current .hip file option on the shelf tool.

For the environment variable, make sure it points to the actual executable:

PDG_IMAGEMAGICK="C:/Program Files/ImageMagick-7.0.8-Q16/magick.exe"
Edited by BrandonA - March 16, 2019 21:19:36
User Avatar
Member
363 posts
Joined: Feb. 2013
Offline
Great that worked!

Saved the hipfile in a folder outside of Program Files and then had to point the filepattern nodes to
C:/Program Files/Side Effects Software/Houdini 17.5.173/houdini/pdg/installation_check/input/images.zip 
instead of the relative path.

Then I changed the environment variables to:

PDG_IMAGEMAGICK="C:/Program Files/ImageMagick-7.0.8-Q16/magick.exe"
PDG_FFMPEG="C:/Program Files/ImageMagick-7.0.8-Q16/ffmpeg.exe"

After that I could cook the nodes as expected.
Edited by DASD - March 16, 2019 22:31:49
  • Quick Links