how to hide pyro sim source volume?

   1018   7   3
User Avatar
Member
3 posts
Joined: July 2019
Offline
Hello everyone,

excuse me I'm pretty new to Houdini and this may be a really beginner question
but I'm doing a pyro sim (using 16.5) and i'm sourcing it from fluid source with point stamp (calculated velocities on points)
now everything is working good but i want to hide the source from the final result of the sim, it's sourced using a source volume node inside the DOP network but i don't want it to show up after solving as the points now look like a grainy blob in the middle of my sim

I hope this was clear enough, and I attached the hip file anyway
Edited by EmamFX - July 27, 2019 06:52:37

Attachments:
Pyro_Question.hip (1.3 MB)

User Avatar
Member
280 posts
Joined: July 2012
Offline
No hip file attached! Also, that source is where fuel comes from, so it needs to be visible, because that's the hottest part of what is emitting. If you cut the source after a certain number of frames, then the source will disappear. What I'm trying to say is, it sounds like you are assuming something is a problem that is behaving the way it should be.
User Avatar
Member
85 posts
Joined: June 2016
Offline
Hey EmamFX
yeah sometimes you might need to hide the source as it might appear very dense and visually look bad. in that case you can use VDBcombine SOP and subtract the source volume from your simed volume, but prepare your source volume before subtracting to have a nice fall off other wise you might end up having a harsh edge.

Best,
Mohan Pugaz
Edited by Mohanpugaz - July 24, 2019 06:16:53
Mohan Pugaz
movfx
https://www.instagram.com/movfx/ [www.instagram.com]
https://www.youtube.com/channel/UCn_3oSEcFBsTSoApmkI5Q1Q [www.youtube.com]
User Avatar
Member
3 posts
Joined: July 2019
Offline
Midasssilver
No hip file attached! Also, that source is where fuel comes from, so it needs to be visible, because that's the hottest part of what is emitting. If you cut the source after a certain number of frames, then the source will disappear. What I'm trying to say is, it sounds like you are assuming something is a problem that is behaving the way it should be.
sorry for that attachment mistake, I added the hip file now if you check it you can see that i'm going for some kind of jet engine effect on the the ground so i only want the result of the sim not the source of it and i don't want to turn off the source, just hide it in the render
User Avatar
Member
3 posts
Joined: July 2019
Offline
Mohanpugaz
Hey EmamFX
yeah sometimes you might need to hide the source as it might appear very dense and visually look bad. in that case you can use VDBcombine SOP and subtract the source volume from your simed volume, but prepare your source volume before subtracting to have a nice fall off other wise you might end up having a harsh edge.

Best,
Mohan Pugaz
Thank you very much this makes sense but i'm not getting any result using the vdbcombine SOP and i have no idea why
sorry again i'm still a beginner, and here's the hip file with the vdbcombine SOP

Attachments:
Pyro_Question_VDBcombine.hip (1.2 MB)

User Avatar
Member
1 posts
Joined: Jan. 2020
Offline
Hi there!

I had the same problem this morning and went trying with boolean, volumemix, vdbcombine and volumewrangle.

At the end what helped me achieve what I think you are refering to is to convert the geometry that was going to be used to subtract from the imported pyro simulation using iso offset and subtracting with volume wrangle using the following expression:

f@density *= 1-volumesample(1,0,v@P);



I hope it still helps someone.
Best Regards!
Edited by asanchez - Feb. 6, 2020 06:56:06

Attachments:
isosubtract.JPG (21.0 KB)

User Avatar
Member
85 posts
Joined: June 2016
Offline
Try changing the name of isooffser volume to density.


But I found another useful trick recently which worked best for me in some cases.

If ur source is static and simulation has some movement then the following trick will work, in volume wrangle
Calculate the length of your vel field if it is 0 then density is 0.

@density *= fit(length(@vel),0,0.01,0,1)
Mohan Pugaz
movfx
https://www.instagram.com/movfx/ [www.instagram.com]
https://www.youtube.com/channel/UCn_3oSEcFBsTSoApmkI5Q1Q [www.youtube.com]
User Avatar
Member
2 posts
Joined: Jan. 2017
Offline
With smoke I was able to hide the initial particles emitted from the source mesh (that were giving away the shape too obviously) by setting ‘coverage’ to 0 on the Rasterize node, right after the Pyro Source node. Not sure if that is the same for fluids.
  • Quick Links