POP collision and UE4 problem

   260   2   2
User Avatar
Member
3 posts
Joined: Feb. 2019
Offline
Hey guys,
I do have pretty hard to solve ( of course from my perspective ) problem or more bug:

I created simple HDA with POP, timeshift to try why my particles couldn't draw a mask on my landscape ( but that's a different story ). Then I put it to the UE4 level and collision didn't work, particles were just falling without any collision at all. After that, I tried it out on a
simple level and guess what… it worked. But after trying it on another default level - VR one, it didn't.
I was checking, rather quickly world settings and those were looking the same ( but I could overlook something )

I attach every file that I could and thanks guys in advance for any help!
Edited by jakubmularski - Sept. 25, 2019 09:11:19

Attachments:
POP_HDA_bug_emptymap.png (182.3 KB)
POP_HDA_bug_AnyOtherMap.png (222.4 KB)
popHDA.hiplc (278.1 KB)
Andrzej_popue4test.hdalc (34.5 KB)

User Avatar
Member
3 posts
Joined: Feb. 2019
Offline
From my further investigation if my HDA asset is at 0,0,0 everything is fine, the problem is when it's not there. Then it has a problem with translation, and nothing has to do with the levels. Thanks in advance for further checking what's up.


===========================
UPDATE:

If you put your HDA in 0,0,0 everything is fine and you need to build your POP with that in mind, not so good but it's viable
Edited by jakubmularski - Sept. 25, 2019 11:14:20
User Avatar
Staff
367 posts
Joined: Sept. 2016
Offline
What are you using to bring the collision geometry in Houdini?
An object merge input set to World Outliner?

If that's the case, check that the object merge's transform type parameter in your HDA is set to “into this object” …
that's generally what's causes the “HDA only works at (0,0,0)” issues.
  • Quick Links