UE - Keep World Transform Disabled?

   224   2   0
User Avatar
Member
3 posts
Joined:
Offline
Hi people, i already asked the same question on UE forum, and i wanna to ask the same here…

Ok, so i made my 1st hda tool and i wanna to test it out, its a very simple tool uses input as mesh from UE/Unity, but no matter what i do Keep World Transform is always disabled, so could anyone help me out and tell me what im doing wrong… I saw a tons of videos for HDA and UE but never saw anyone showing the ‘proper’ way to prepare hda for UE (if there are any special way to do that), i mean my tool works fine in Unity and transforms are not locked! Not sure is the problem in HDA or UE…

Thanks
Edited by bazuka - Oct. 16, 2019 02:33:48

Attachments:
Annotation 2019-10-16 071009.jpg (287.6 KB)

User Avatar
Staff
367 posts
Joined: Sept. 2016
Offline
Hi,

That's the way things are supposed to be.
You're using a geometry input, which fetches meshes from the content browser and send them to Houdini.
Since that mesh comes from the content browser, it has no “World Transform”, which is why the option is greyed out.

If your mesh was placed in the world, you'd use a “World input” to select the actor, in that case, the option wouldn't be greyed out, since the actor would have an actual world transform.
Looking at your screenshot, if your goal was to use the cube actor (behind your hda), then a world outliner input is what you should be using.
User Avatar
Member
3 posts
Joined:
Offline
Thx for reply mate, i was able to make it work

cheers
  • Quick Links