Color Picker (from image) in 18.5

   1574   8   2
User Avatar
Member
36 posts
Joined: June 2016
Offline
Hello,

I am facing some issues with the color picker in 18.5. There seem to be some changes in the 18.5 version, and I am not able to get the results I used to get in Houdini 18. If I try to pick color from an image (mostly Jpg/Png in my case) I always get different results, compared to the previous version. I tried all kind of settings from the drop down menu, but nothing seems to work.

Does anyone know which settings give the same result as the older version of Houdini?

Thanks

Edited by Xue_Yue - Nov. 13, 2020 11:00:34
User Avatar
Member
4636 posts
Joined: Sept. 2011
Offline
It's broken, there doesn't seem to be any set of settings that make color picking correct for any situation.
User Avatar
Member
36 posts
Joined: June 2016
Offline
Hello,
yeah, it seems to be incorrect. I used this feature a lot, so I'm looking forward to the fix. Thanks for looking into it and confirm my observations. Does anyone know if there is an RFE already?
User Avatar
Member
34 posts
Joined: Jan. 2009
Offline
This seems to be still broken in 18.5.408. Any updates?
User Avatar
Member
7 posts
Joined: June 2020
Offline
You need to set correct picking color space. If you looking at srgb image, you should set pick color space to srgb.
In my case I use ACEScg and it works perfectly

Attachments:
2021-01-28_11-45.png (281.3 KB)

User Avatar
Member
34 posts
Joined: Jan. 2009
Offline
Hi Thanks for your response,


I have tried setting the color space to srgb but that didnt work. I am also having problems picking colors from ramps and things.
For example I am trying to pick the color from the reflections which is (007FFF) when i pick I get (00BCFF). I have tried a few combinations of settings but nothings worked so far. turning off apply color correction seems to help.

Attachments:
color issues.png (101.5 KB)

User Avatar
Member
36 posts
Joined: June 2016
Offline
Hey, I just want to say that this still doesn't seem to work as it did in older versions of houdini. We don't use ACES here, maybe it works with ACES (as stated above). But when I load a simple sRGB to pick colors it is impossible to get the right values and I think I tried every possible combination available (logical and nonsense settings, just to be sure).

Should this be an RFE or a bug report? Anyone else using this without acceptable results?
Edited by Xue_Yue - May 28, 2021 12:34:18
User Avatar
Member
34 posts
Joined: Jan. 2009
Offline
Hi I also have problems with this. I was unable to pick colors from external images as well as internal. I can now pick colors from an external image but if i load the image it still has issues.

In my case i realised that the issue was the apply color correction button. It seems to be buggy i have to turn it on and off to get the colors to work.
User Avatar
Member
1 posts
Joined: Aug. 2019
Offline
Hi
I've resolved the problem by going to Edit/Color Settings/Color Correction and unchecking "Color Pickers and Swatches".
I hope it helps
  • Quick Links