Internal Documentation Browser Extremely Slow

   3208   10   1
User Avatar
Member
17 posts
Joined: Oct. 2017
Offline
I am sure this is a known issue - but the internal help browser is very slow and often unresponsive.

I have been using external help just fine...

Does this happen for everyone?

Just wondering....

Thanks for any insight
User Avatar
Member
17 posts
Joined: Feb. 2017
Offline
I`ve been using external browser and it`s been fine for me H17 and up. Here is my setup for it via packages. Hope that helps!
Image Not Found
,
Edited by psanitra - Jan. 21, 2021 11:23:41

Attachments:
HelpBrowser.json (199 bytes)

User Avatar
Member
671 posts
Joined: Sept. 2013
Offline
Yes, it is very slow for years now on any OS I think. I hope the developers will address this issue and also turn the background dark.

At the moment some users fix it for themselves, but it's definitely not very welcoming.
https://procegen.konstantinmagnus.de/ [procegen.konstantinmagnus.de]
User Avatar
Member
237 posts
Joined: June 2006
Offline
Yep. Didnt figured it out: sometime it behaves normal, sometimes its pretty slow, sometimes it dont work at all.
Imho it urgently needs a maintenance.
User Avatar
Member
41 posts
Joined: Dec. 2016
Offline
It loads very slow starting with H18.5 for me on Windows 10. Also, embedded videos, like the ones for help cards in SideFx Labs tools are broken and won't play.
User Avatar
Member
7865 posts
Joined: Sept. 2011
Offline
bobcober0
Does this happen for everyone?

No, it works fine for me since 18. It used to be pretty flakey before.
User Avatar
Member
1750 posts
Joined: May 2006
Offline
Still broken here, windows 10 and osx, 18.5.

Watching the help page load for the 'labs flowmap visualize' sop, 2 mins so far. Video playbar is there, but no video. All the little icons for the rest of the sops in the left-hand nav bar are slooowly loading in, I assume once they finish, the video will appear.

*time passes*

Nope, no video. Frustrating.
http://www.tokeru.com/cgwiki [www.tokeru.com]
https://www.patreon.com/mattestela [www.patreon.com]
User Avatar
Member
7865 posts
Joined: Sept. 2011
Offline
mestela
Still broken here, windows 10 and osx, 18.5.

Watching the help page load for the 'labs flowmap visualize' sop, 2 mins so far. Video playbar is there, but no video. All the little icons for the rest of the sops in the left-hand nav bar are slooowly loading in, I assume once they finish, the video will appear.

*time passes*

Nope, no video. Frustrating.

Is it only slow for 3rd party help pages with video? I don't recall using any help pages with embedded video, nor do I have labs installed. Perhaps 3rd party plugin help doesn't get indexed the way the native help does.

The slow icons in the sidebar behavior I haven't seen since 17.5. I remember it used to be really slow until it parsed all the icons, but since 18.0 it does some indexing on the first launch that speeds it up. Having the help folder in config stored on fast storage helps a lot. You can keep the rest of your home folder on the network though.
User Avatar
Member
8 posts
Joined: June 2020
Offline
psanitra
I`ve been using external browser and it`s been fine for me H17 and up. Here is my setup for it via packages. Hope that helps!
Image Not Found
,

Thanks for this. I had to alter it a bit for me to work:

{"HOUDINI_EXTERNAL_HELP_BROWSER" :[
            {
                "value": "1",
                "method": "replace"
            }]
Notice square brackets before curly ones.
Edited by MikasSadas - Jan. 28, 2021 03:53:38
User Avatar
Staff
424 posts
Joined: Feb. 2018
Offline
Why the brackets ? HOUDINI_EXTERNAL_HELP_BROWSER is just a regular env variable.
User Avatar
Member
19 posts
Joined: June 2017
Offline
Konstantin Magnus
Yes, it is very slow for years now on any OS I think. I hope the developers will address this issue and also turn the background dark.

At the moment some users fix it for themselves, but it's definitely not very welcoming.
HOUDINI_EXTERNAL_HELP_BROWSER = 1 //works fine for me
You can force Dark Mode in Chrome via "chrome://flags" and enable "Force Dark Mode for Web Contents".
Same goes for the new chromium-based Edge browser, Again, "edge://flags/" and enable "Force Dark Mode for Web Contents". Play around with "Enable selective inversion of everything" or other options instead of default settings to tweak it to your needs.
  • Quick Links