Volume rendering

   1435   2   1
User Avatar
Member
2 posts
Joined: Feb. 2021
Offline
Hi, I am facing a weird problem , volume rendering with karma, here two results of rendering, In viewport rendering it looks good, but after rendering it isn't , how to fix it, please help

Attachments:
viewport.jpg (50.3 KB)
render.jpg (36.4 KB)

User Avatar
Member
54 posts
Joined: Sept. 2008
Offline
You can let the environment rendered in the environment light settings.
Edited by ifree - July 18, 2023 00:48:15
User Avatar
Member
58 posts
Joined: Nov. 2021
Offline
There's a couple of things you could check:

1. Inside your volume shader make sure the smoke color is actually set to something else than black and shadow color and density to mess with your volume.

2. On your light under the Karma tab make sure the light contributions includes volumes, by default it should be an asterisk so everything is included.

3. In case you used the Render Geometry Settings node for the volume, check the volume settings.

4. In the Karma Render Settings check volume samples and increase if necessary.
  • Quick Links