Viewport preview inside Vellum Solver

   1205   8   2
User Avatar
Member
1 posts
Joined: May 2022
Offline
Hello all,

This is a bit of a newbie question but I'm following some tutorials on Vellum and everyone seems to be able to preview their sims while inside a Vellum Solver. However, I can't seem to do this. When I press play the sim is just frozen on the current frame unless I go up to the top geo level.

I've tried turning various knobs in order to make it work but nothing seems to improve the situation. Can someone help as it would save me a whole bunch of button clicking?!

Thanks
DT
User Avatar
Member
228 posts
Joined: Feb. 2016
Offline
meshmashuk
Hello all,

This is a bit of a newbie question but I'm following some tutorials on Vellum and everyone seems to be able to preview their sims while inside a Vellum Solver. However, I can't seem to do this. When I press play the sim is just frozen on the current frame unless I go up to the top geo level.

I've tried turning various knobs in order to make it work but nothing seems to improve the situation. Can someone help as it would save me a whole bunch of button clicking?!

Thanks
DT

I was about to report that as a bug. The issue isn't actually with the vellum solver. In houdini 20, if you create a subnet in a dopnet, the viewport won't update when inside the subnet. When you double click the vellum solver sop to go inside, it actually takes you inside a subnet in the dopnet, hence why it doesn't work. You can re-create the issue like this:

1. Create a sphere and select it
2. In the rigid body shelf on the right click RBD objects
3. Go inside the autodopnet
4. create a subnetwork
5. attach the subnetwork to the post solve of the rigidbodysolver node
6. go inside the subnet

you will notice the viewport will not update.

going to report this issue now.

update: known bug
Edited by evanrudefx - March 6, 2024 16:07:27

Attachments:
Animation.gif (10.1 MB)

Thanks,

Evan
User Avatar
Member
8 posts
Joined: Nov. 2020
Offline
Hey, is this fixed? Even now at 20.0.717 it's like this for me. It's extremely frustrating!
User Avatar
Member
228 posts
Joined: Feb. 2016
Offline
mike_keys
Hey, is this fixed? Even now at 20.0.717 it's like this for me. It's extremely frustrating!
no, support told me it would not be fixed until next version. kinda insane that all houdini 20 will have this bug.
Thanks,

Evan
User Avatar
Member
8647 posts
Joined: July 2007
Offline
As a workaround you can pin the viewport when outside of the solver
Tomas Slancik
FX Supervisor
Method Studios, NY
User Avatar
Member
8 posts
Joined: Nov. 2020
Offline
Yes, you can! But you don't have any visual feedback on any of the pop nodes, gas nodes, etc!
User Avatar
Member
2 posts
Joined: Jan. 2024
Offline
this bug is extremely frustrating I can't believe they won't fix it, I feel it's a shame honestly however I found the only way to work and visualize pop forces is to build a dopnet with vellum solver and vellum object its so far the easiest way, pinning the viewport doesn't work you can't work with forces which makes vellum useless anyway

Attachments:
Screenshot 2024-05-30 234337.png (71.6 KB)

User Avatar
Member
8647 posts
Joined: July 2007
Offline
Maybe you can try this build

20.0.724
Fixed viewer update of a SOP Solver sim when inside the solver.
Tomas Slancik
FX Supervisor
Method Studios, NY
User Avatar
Member
2 posts
Joined: Jan. 2024
Offline
tamte
Maybe you can try this build

20.0.724
Fixed viewer update of a SOP Solver sim when inside the solver.
I've seen on the changelog clearly this update but still I'm having the same issue it's weird does it have anything to do that I install from launcher maybe?
  • Quick Links