Diffuse Filter (No Lighting info) pass is missing.

   181   4   0
User Avatar
Member
9 posts
Joined: 1月 2008
Offline
Hey guys, I'm trying to do multi pass rendering but diffuse filter pass seems not working (same for specular roughness etc), I use “Surface Unlit Diffuse Color” component but its rendering dark. What i noticed is if I use the build in texture parameter in the principled material diffuse filter shows up and working but when i wire texture nodes to principled shader it doesnt work any tips?

I attached a scene which i have 2 individual spheres one with working shader the other one is the problematic one.

thanks!

Attachments:
diffuseprob.jpg (133.4 KB)
DiffuseFilterPass_Problem.hip (1.7 MB)

User Avatar
Member
3029 posts
Joined: 9月 2011
Offline
Does it go away when you append a surface exports to the problematic one?
User Avatar
Member
9 posts
Joined: 1月 2008
Offline
jsmack
Does it go away when you append a surface exports to the problematic one?

Thanks for your reply! i tried literally everything no luck
User Avatar
Member
3029 posts
Joined: 9月 2011
Offline
Oh, that's one of the layer exports, isn't it? It's normally disabled for non-baking renders. It's enabled by adding “Add Baking Exports to Shader Layers (vm_bake_layerexport)” to the mantra node and setting it True. This setting can be expensive though, in some cases making renders take 2-3x longer. It might get better performance to export it manually be appending a bind export to the texture going into the principled shader's basecolor input.

See the attached scene for examples of adding the proper exports.
Edited by jsmack - 2020年2月15日 13:15:06

Attachments:
DiffuseFilterPass_Problem_fix.zip (154.8 KB)

User Avatar
Member
9 posts
Joined: 1月 2008
Offline
jsmack
Oh, that's one of the layer exports, isn't it? It's normally disabled for non-baking renders. It's enabled by adding “Add Baking Exports to Shader Layers (vm_bake_layerexport)” to the mantra node and setting it True. This setting can be expensive though, in some cases making renders take 2-3x longer. It might get better performance to export it manually be appending a bind export to the texture going into the principled shader's basecolor input.

See the attached scene for examples of adding the proper exports.

Thanks A lot Jonathan! that was what i am looking for, the first wsy is a bit too long to setup especially considering i have 40+ materials in the master scene but baking export should do the trick! thanks again
  • Quick Links